Results 1 to 3 of 3
  1. #1
    ROG Enthusiast Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    49

    G75VX Touchpad buttons don't work!! Need help with Drivers

    Hi everyone.

    I've been having this problem since I updated the drivers on my laptop. My touchpad buttons don't work, no matter what drivers I try to install. Everything else worked, and I had resigned to the fact that this was never going to work (mostly because I usually use a mouse and when I'm not I can tap the pad with one finger for LMB or tap with two fingers for RMB), but recently I tried to fix this problem by looking for updated drivers.

    Big mistake. After trying to fix it, the FN+F9 problem came back and it took me a day of trying to find a driver that would solve this. Now I finally found one, since I moved to another country and don't have the original drivers CD with me; but it's a different (older?) driver and I now have different animations when using different FN buttons. Example:
    when using the volume up and down I get this: http://i.imgur.com/VxCYPYV.jpg
    When using the disable touchpad I get this: http://i.imgur.com/xxgHdKj.jpg

    Which as you can imagine is very annoying. It doesn't help that the Asus website drivers pages seems to be either down for maintenance or not working at all so I can't get any drivers from there.

    Anyway, I still couldn't find any drivers that made my touchpad buttons work, and I'm beginning to think that this could be a hardware issue.
    Does anyone else have this problem?

    I'm using windows 10, 64bits
    I'm have a Smart Gesture touchpad, not Elan.

    Help me, Obi-Wan Kenobi... You're my only hope.
    Last edited by BuLaXa; 02-21-2016 at 05:36 PM.
    Asus G75VX-T4022P
    Processor: Intel i7 3630QM
    Memory: 32GB (4*8GB 1600Mhz)
    Storage: 256GB SSD + 750GB 7200rpm
    Screen: Matte 17.3" LED FHD / NG
    Graphics: NVIDIA GTX670MX, GDDR5 3Gb
    Wireless: 802.11ac + Bluetooth 4.0
    OS: Windows 8.1 Pro (x64)

  2. #2
    ROG Enthusiast Array Miliano PC Specs
    Miliano PC Specs
    Laptop (Model)G74SX-BBK7-A1
    MotherboardRev 2.0 2D
    ProcessorI7 2860QM (Aftermarket)
    Memory (part number)32GB 1333Mhz CL9
    Graphics Card #13GB GTX560M (2D)
    Monitor1920x1080p
    Storage #1850 EVO 1TB SSD
    Storage #2Hitachi 1TB HDD
    Power Supply180w
    Mouse Razer Oroborous
    Mouse Pad Synaptics TP
    OS WIN 10 PRO
    Network RouterASUS RT-AC87U
    Miliano's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    30

    your TP buttons should definately be working, regardless if the ATK driver and/or TP drivers are installed or not, as windows (especially win 10) will install its own driver for this, so this maybe be a hardware issue.

    And the images you provided in regards to volume and TP disable are from the older style ATK driver package (Win 7-8.1).
    By rights, you should be able to download and install a newer version of the ATK package, even if its from a newer ASUS ROG gaming laptop that was released with WIN 10,
    example

    I am using the ATK driver (Version 1.0.0039) from G750JM found here
    on my G74sx (which is older than yours) with Win 10 pro. all is working fine.

    Head to "Programs and Features" (WinKey + x) then F key will open it,
    Uninstall the Current ATK package first, then reboot.
    Once rebooted, install new downloaded package and reboot again.

    You should be able to do the same with ASUS Smart Gesture TP drivers too if the newer laptops use that TP, but from what im seeing, on asus, your laptop uses Synaptics TP, so you should try Synaptics drivers.

    To check which TP is used,
    1.Open Device Manager (WinKey + X) then M key
    2. expand "Mice and other Pointing Devices"
    right click on ps/2 port conpatible TP (if your using an external mouse you might have 2 options) and choose properties/details
    in the drop down menu, you will see "Device instance path" and "hardware ID's" and "Compatible ID's".

    if you see "SYN" in any of those, you are using a Synaptics TP.
    Alternatively you can copy the value from "Device Instance Path" and search the NET to see what if comes back for that ID.

    Unfortunately ASUS has dropped Synaptics TP from their G series line so no more updates to the drivers, latest from ASUS for G75vw is v16.XXX.
    so the best/latest Synaptic driver i could get working on my sys is version 17.0.18.0, they have v19+ now, but Synaptics have been really slack with their drivers, not signing them properly etc.

    IF you do have the Synaptics TP, and cant find the 17.0.18 driver on the NET (not on ASUS, or Synaptics Websites unfortunately) PM me and i will upload to Google Drive for you.
    and it was hard to find, just keep digging.

    Hope this helps.



    See how you go.
    Last edited by Miliano; 02-24-2016 at 12:24 AM.
    ROG G74SX-A1-BBK7

    UPGRADES
    RAM: 32GB @ 1333Mhz
    CPU: I7-2860QM 3.6ghz 8Mb Cache
    TouchPad: SYNAPTICS (from a G73sx)
    SCREEN: 1920x1080p screen
    WIFI CARD: INTEL 7260AC 867mbps Dual Band/bluetooth
    DRIVE 1: 850 EVO 1TB SSD
    DRIVE 2: Hitachi 1TB HDD
    DRIVE 3 (optical Bay): 500GB HDD

  3. #3
    ROG Enthusiast Array Miliano PC Specs
    Miliano PC Specs
    Laptop (Model)G74SX-BBK7-A1
    MotherboardRev 2.0 2D
    ProcessorI7 2860QM (Aftermarket)
    Memory (part number)32GB 1333Mhz CL9
    Graphics Card #13GB GTX560M (2D)
    Monitor1920x1080p
    Storage #1850 EVO 1TB SSD
    Storage #2Hitachi 1TB HDD
    Power Supply180w
    Mouse Razer Oroborous
    Mouse Pad Synaptics TP
    OS WIN 10 PRO
    Network RouterASUS RT-AC87U
    Miliano's Avatar
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    30

    Quote Originally Posted by BuLaXa View Post
    Hi everyone.
    I've been having this problem since I updated the drivers on my laptop.
    Ps i would also look at reinstalling the audio driver.
    ROG G74SX-A1-BBK7

    UPGRADES
    RAM: 32GB @ 1333Mhz
    CPU: I7-2860QM 3.6ghz 8Mb Cache
    TouchPad: SYNAPTICS (from a G73sx)
    SCREEN: 1920x1080p screen
    WIFI CARD: INTEL 7260AC 867mbps Dual Band/bluetooth
    DRIVE 1: 850 EVO 1TB SSD
    DRIVE 2: Hitachi 1TB HDD
    DRIVE 3 (optical Bay): 500GB HDD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •