Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    GL752VW Clean Format and Buzzing Sound

    Hello, I just bought a GL752VW a week ago, everything was fine until I decided to make a clean W10 format and things got complicated. After the format I've discovered a buzzing sound from the lower left corner that identical with my Mouse scrolling and the performance is dropped as well, I get sudden fps drops in some games like CS:GO.

    Can you guys help me about my next action? Is it possible that I can make a -out the box- Windows 10 recovery? Or the best thing to do is sending the computer to the tech support?

    Please guide me through this, thank you

  2. #2
    ROG Enthusiast Array pigulici's Avatar
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    69

    After clean install of win10 you installed the drivers from asus?

  3. #3
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    Click image for larger version. 

Name:	drivers.jpg 
Views:	26 
Size:	55.0 KB 
ID:	55935


    Yes I have installed the drivers above, just couldnt install Splendid it shows an error code while installing. Additionally installed the latest Geforce driver too.

    Edit: Asus Live Update wont boot too.

  4. #4
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    Update: Well it seems the buzzing sound is a hardware issue and I will demand a replacement.
    Last edited by noyan00; 03-02-2016 at 02:29 PM.

  5. #5
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    Hello? up

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •