Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Feb 2016

    HUGEEEEE Issues with G20aj ROG desktop

    Soooo, Here it goes I am looking for some advice please with people that have knowledge on what I need to do/ what has happen or give me something to go on.

    I purchased a Rog G20aj over a yr ago, a few months ago i started having some issues with blue screens then it would just be so laggy when i would boot up an it would give me a blue circle circling with everything i would try to open up an would seem like it was taking forever to just load something up. i tried everything i possibly could think of doin from virus scans to dfragging, restore points etc an nothing was helping it . so a friend of mine that is a computer guy told me to go ahead an reinstall windows so i went to do that an when i did i wasnt able to go back an put win 8.1 on it becuase it wouldnt allow me no reason why. i called asus an they wouldnt give me the prod key or nothing called microsoft an same issue so i had no choice but to puchase a new key for it.

    installed win 10 an it worked perfectly fine no issues what so ever loved it..
    so then over a month ago i started to have the same issues again and recieved blue screens that said critical process died. so i tried to boot it back up and it was jjust lagging something fierce so i said fine i have usb windows i can reinstall it so i did that an it reinstalled i was able to get onto the desktop an it was so laggy again then gave me the same blue screen remind u i had not even installed anything else other then windows.

    so i went to reboot after the windows install an the blue screen an it would only load into bios i would try to load into the desktop an same thing . so i have a friend that said that rogs have to have a special way of installing windows i had not tried it at that time becuas ei sent the pc into the repair shop to get a diagnostics on it they charged me 29.00 i got it back not fixed i want to hear what u all think could possibly be the issue before i tell u what they have told me. any reply would be appreciated.

  2. #2
    ROG Enthusiast Array
    Join Date
    Dec 2015

    Your description is poor at best and makes it nearly impossible to diagnose. I don't know what you tried to install because this is a UEFI bios and the registration key is imbedded into it so you should not have had problems reinstalling the original OS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts