Results 1 to 3 of 3
  1. #1
    ROG Member Array Dany Gee PC Specs
    Dany Gee PC Specs
    MotherboardASUS Z170 Deluxe
    ProcessorIntel i7-6700K
    Memory (part number)32 GB Gskill Ripjaws 4 @ 3000 Mhz (DDR4)
    Graphics Card #1ASUS GTX980Ti Strix
    Storage #1Samsung Pro 850 256 GB
    Storage #2Samsung Pro 850 1TB
    CPU CoolerNZXT Kraken X61
    CaseNZXT H440 (White)
    Power SupplySeasonic X660 (660W)
    Keyboard Razer Anansi
    Mouse Razer Imperator 2012
    Headset Sennheiser PC330 G4ME
    Mouse Pad Razer Kabuto
    OS Windows 10 Pro 64bit

    Join Date
    Jan 2016
    Reputation
    10
    Posts
    6

    Asus Z170 Deluxe an Razer Anansi compatibility

    Hello,

    I have a strange hardware issue between Z170 Deluxe and Razer Anansi Keyboard.
    Scenario:
    Turning computer from complete power off (no hibernation) and all my devices except the keyboard are recognized during boot.
    Simple re-replug however makes the keyboard work without problems, even after restarts but only till the next complete shutdown. Then the problem repeats itself.

    Already checked:
    1. Default old bios.
    2. Default new bios 1602.
    3. All drivers installed and updated.
    4. Keyboard firmware updated.
    5. Tested on both W7 and W10 (but I think its not a system related issue - I need the keyboard to be active during POST).
    6. Keyboard gets discovered during POST on 3 other machines in the house without problems.
    7. Old A4tech K126 keyboard gets discovered without problems by Z170 Deluxe.
    8. Tested every port (2.0/3.0/3.1, front, back) with other devices connected and with keyboard connected only.
    9. USB options in bios tested on/off (legacy mode, XHCI etc)

    The only bios option which made a difference was "Advanced Menu\APM Configuration\ErP Ready -> Disabled" - the keyboard gets discovered after power on and the MB even remembers my last LED settings (from Asus Lightning control). BUT, the shutdown is not complete in that case - the LEDs from Kraken X61 and from GPU stay on, what is hard to bare in the night.

    Changing the Advanced Menu\APM Configuration\ErP Ready to "Enabled S4" or "Enabled S4+S5" gives a complete shutdown (nothing stays on) but the keyboard is not recognized and LED settings are reset.

    Did someone have a similiar problem with that board?

  2. #2
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,370

    Hello Danny Gee

    I'm using the Razer Anansi with no issues on the maximus viii formula. The lights on the motherboard stay on after I shut it down and my keyboard is recognized and working when I start my pc. I have it connected to the usb 3.0 ports on the motherboard, one for the keyboard and one for the lights on the keyboard.

  3. #3
    ROG Member Array Dany Gee PC Specs
    Dany Gee PC Specs
    MotherboardASUS Z170 Deluxe
    ProcessorIntel i7-6700K
    Memory (part number)32 GB Gskill Ripjaws 4 @ 3000 Mhz (DDR4)
    Graphics Card #1ASUS GTX980Ti Strix
    Storage #1Samsung Pro 850 256 GB
    Storage #2Samsung Pro 850 1TB
    CPU CoolerNZXT Kraken X61
    CaseNZXT H440 (White)
    Power SupplySeasonic X660 (660W)
    Keyboard Razer Anansi
    Mouse Razer Imperator 2012
    Headset Sennheiser PC330 G4ME
    Mouse Pad Razer Kabuto
    OS Windows 10 Pro 64bit

    Join Date
    Jan 2016
    Reputation
    10
    Posts
    6

    Quote Originally Posted by Nate152 View Post
    Hello Danny Gee

    I'm using the Razer Anansi with no issues on the maximus viii formula. The lights on the motherboard stay on after I shut it down and my keyboard is recognized and working when I start my pc. I have it connected to the usb 3.0 ports on the motherboard, one for the keyboard and one for the lights on the keyboard.
    Thx for the information! Please also check the bios version and following settings in it (if possible):
    1. Advanced Menu\APM Configuration\ErP Ready
    2. USB Configuration\ (Legacy,XHCI Handoff and PS2 emulation settings)

    Either text or screenshots will do

    Thx in advance!
    Last edited by Dany Gee; 03-01-2016 at 07:27 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •