Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    New ROGer Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    4

    Smile Asus G53SW-A1 Keyboard not lighting

    Hi,

    I'm pretty new to computers and new to this site, so please bear with me. Few months ago I bought an Asus G53SW-A1 laptop, everything works perfectly fine except two problems.

    Number one, the keyboard used to light up but 2 days after purchase it stopped working... It does light up for a few seconds when you boot it up.

    Number two, directly related or might even be the cause of #1, the three buttons on the top left corner of my keyboard I think as well stopped working.
    Click image for larger version. 

Name:	url.jpg 
Views:	74 
Size:	78.9 KB 
ID:	5154
    One of these buttons are for switching on/off the keyboard backlit, another controls the power mode, and the third one I don't know.. The button for switching on the backlit is the only way I know how to light up the keyboard, and when I press it, the 3 buttons and the power button are the only ones that light up, the rest is still in the dark. I have tried using other ways but it didn't work out. Any suggestions?

    Another side question, what's the difference between Intel boost and overclocking? I use my laptop mostly on High Performance, would that hurt my laptop?

  2. #2
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2011
    Reputation
    14
    Posts
    337

    it is a common issue. reinstall ATK, reboot, and press FN key to light them up
    regarding the 3 keys i don't know. i have a g74 which only has 2.

  3. #3
    New ROGer Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    4

    Can you give me a link to download the ATK? I don't know what it is.

  4. #4
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey and double-click HControl.exe to execute it. Does this resolve your backlight issue?

    If not, UNinstall your current ATK Package from "Control Panel - Uninstall a program", REBOOT (Don't forget it!), then download your system's most recent ATK Package from http://support.asus.com/Download.asp...53SW&p=3&s=282 (you'll need to specify the OS) and install it.

    The ATK Package Drivers control the function keys on your laptop. Alternatively, you could install the 1.00.0014 version ATK Package from the link in the OP of the "Drivers, Apps, and How-to's" thread. However, some believe the ATK Package drivers may be model-specific. I'm currently running this version, but it was specified in conjunction with BIOS 202 to resolve a missing keystroke issue on the G74SX laptops.
    Last edited by dstrakele; 12-27-2011 at 05:02 AM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  5. #5
    ROG Member Array DexSky's Avatar
    Join Date
    Dec 2011
    Reputation
    11
    Posts
    18

    Hey.. i got the same exact problem after doing windows update.. after clicking on the HControl.exe.. it solves all the 3 buttons on the top left and my keyboard lights up again.. THX for the help.. Why does this happen after windows update? O.O

    1 more thing... my windows explorer keeps on crushing and i gotta keep on restart the windows explorer.. any suggestion?

  6. #6
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Quote Originally Posted by DexSky View Post
    Hey.. i got the same exact problem after doing windows update.. after clicking on the HControl.exe.. it solves all the 3 buttons on the top left and my keyboard lights up again.. THX for the help.. Why does this happen after windows update? O.O

    1 more thing... my windows explorer keeps on crushing and i gotta keep on restart the windows explorer.. any suggestion?
    It's possible that a Windows update could interfere with the running of HControl.exe at startup. You may want to launch MSCONFIG.EXE, select the "Startup" tab and confirm "ATK Hotkey" has its checkbox checked so it runs at Startup. Then reboot your system and confirm the lights still work.

    If they don't, you'll need to use Windows System Restore to restore your system to a point before the updates were installed. If this resolves your light issues, then install the updates one at a time to see which one causes the issue.


    ASUS WebStorage has been implicated in EXPLORER.EXE crashes, but there is also a Windows update that addresses this issue. Google "Windows Update Explorer.exe crashes" to find that update and determine if you have it installed. If so, then try UNinstalling "ASUS WebStorage" from "Control Panel - Uninstall a program".
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  7. #7
    ROG Member Array DexSky's Avatar
    Join Date
    Dec 2011
    Reputation
    11
    Posts
    18

    Quote Originally Posted by dstrakele View Post
    Go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey and double-click HControl.exe to execute it. Does this resolve your backlight issue?

    If not, UNinstall your current ATK Package from "Control Panel - Uninstall a program", REBOOT (Don't forget it!), then download your system's most recent ATK Package from http://support.asus.com/Download.asp...53SW&p=3&s=282 (you'll need to specify the OS) and install it.

    The ATK Package Drivers control the function keys on your laptop. Alternatively, you could install the 1.00.0014 version ATK Package from the link in the OP of the "Drivers, Apps, and How-to's" thread. However, some believe the ATK Package drivers may be model-specific. I'm currently running this version, but it was specified in conjunction with BIOS 202 to resolve a missing keystroke issue on the G74SX laptops.
    by the way.. by clicking on the HControl.exe ... it only activates back the light temporarily... and the worse part is that i got to click it after everytime i restart computer..
    well.. 1 thing that i learned is.. u dun have to uninstall the ATK package.. u can just download the setup and REPAIR it.. it works fine for me.. my keyboard is back to normal now.

    Thx for the advice to solve my problem..
    Last edited by DexSky; 12-28-2011 at 05:33 PM.

  8. #8
    New ROGer Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    4

    Quote Originally Posted by dstrakele View Post
    Go to C:\Program Files (x86)\ASUS\ATK Package\ATK Hotkey and double-click HControl.exe to execute it. Does this resolve your backlight issue?

    If not, UNinstall your current ATK Package from "Control Panel - Uninstall a program", REBOOT (Don't forget it!), then download your system's most recent ATK Package from http://support.asus.com/Download.asp...53SW&p=3&s=282 (you'll need to specify the OS) and install it.

    The ATK Package Drivers control the function keys on your laptop. Alternatively, you could install the 1.00.0014 version ATK Package from the link in the OP of the "Drivers, Apps, and How-to's" thread. However, some believe the ATK Package drivers may be model-specific. I'm currently running this version, but it was specified in conjunction with BIOS 202 to resolve a missing keystroke issue on the G74SX laptops.
    Hi,

    Your advice did help me, and I thank you for that. But there is still one problem. I recovered the functionality of the three buttons on the top left corner and I am able to use them; however, I cannot make the entire keyboard turn their back-lights on. The issue still remains that only the buttons on the very top lights up, and the actual usable keyboard does not.

  9. #9
    ROG Member Array DexSky's Avatar
    Join Date
    Dec 2011
    Reputation
    11
    Posts
    18

    Quote Originally Posted by OneTwoThree View Post
    Hi,

    Your advice did help me, and I thank you for that. But there is still one problem. I recovered the functionality of the three buttons on the top left corner and I am able to use them; however, I cannot make the entire keyboard turn their back-lights on. The issue still remains that only the buttons on the very top lights up, and the actual usable keyboard does not.
    did you try to press Fn + F4 ?

  10. #10
    New ROGer Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    4

    Wow I'm so stupid. Problem solved, thanks for the help!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •