Results 1 to 9 of 9
  1. #1
    jameskirl
    Guest

    Help - DVD Drive

    Need some help with my DVD Drive
    G73JW - Slimline Type BD E DS4E1S

    I don't normally use my optical drive and can't really remember the last time I used it.
    Wanted to burn a DVD today but the DVD is not being recognised - just get the message "Insert a disc".
    Listening to the drive it does spin up but the disc is not being recognised.

    I tried a Music CD and Movie DVD and same result - nothing is recognised.

    Also tried to uninstall the drive, rebooted and windows automatically reinstalled but same result - no discs recognised.

    Any tips on what to do next?

    Thanks in advance for the help.

  2. #2
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Does Windows Explorer fail to display files on a CD or DVD that has content written to it?

    Or does Roxio CinePlayer fail to recognize the disk?

    Does the solution in http://support.microsoft.com/kb/982116 resolve your issue?
    Last edited by dstrakele; 12-27-2011 at 02:46 AM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  3. #3
    Retired MOD and Reviewer Array
    Join Date
    May 2011
    Reputation
    25
    Posts
    554

    download ImgBurn, its free

    Tools, filter driver load order. capture the window and provide it in this thread.

    Usually or at least sometimes it is a problem with upper filters and this will show us what you have on your system

  4. #4
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    5

    capture the window and provide it in this thread.



  5. #5
    jameskirl
    Guest
    Quote Originally Posted by PiaRowley View Post
    capture the window and provide it in this thread.


    The issue is the entire drive. It is shown on WIndows Explorer but no discs are recognised whether DVD or CD.

    When I insert a disc there is no prompt to open it. When I select the drive on explorer I get a message telling me to insert a disc even though a disc is already in there

    Thanks for any help. I checked the microsoft link but no I don't have those KB errors.


  6. #6
    ROG Member Array
    Join Date
    Oct 2011
    Reputation
    10
    Posts
    14

    I have the same problem

  7. #7
    New ROGer Array
    Join Date
    Jan 2012
    Reputation
    10
    Posts
    2

    Same problem here too !

  8. #8
    No Longer Works at ASUS Array
    Join Date
    Jul 2012
    Reputation
    68
    Posts
    764

    Have you tried deleting the upper and lower filters from the registry?

    http://pcsupport.about.com/od/driver...werfilters.htm

  9. #9
    ROG Enthusiast Array DUST DEVIL's Avatar
    Join Date
    Dec 2011
    Reputation
    13
    Posts
    31

    Quote Originally Posted by Kipper View Post
    download ImgBurn, its free

    Tools, filter driver load order. capture the window and provide it in this thread.

    Usually or at least sometimes it is a problem with upper filters and this will show us what you have on your system
    Hi!

    I have same problem. My drive worked perfectly but when I tried to copy DVD with Nero 10 something went wrong and now it's not working. I deleted UpperFilter (there was no LowerFilters) but still not working...

    My computer: ASUS G74SX-1ATY

    Click image for larger version. 

Name:	screenwmg.jpg 
Views:	31 
Size:	286.3 KB 
ID:	10912

    Please help!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •