Results 1 to 5 of 5
  1. #1
    ROG Member Array Wowerus PC Specs
    Wowerus PC Specs
    MotherboardHero VIII Hero
    ProcessorI7-6700K Skylake
    Memory (part number)Corsair Vengeance LPX DDR4 2133MHz
    Graphics Card #1GTX 1080 Strix Asus
    MonitorASUS ROG Swift PG278Q x2
    Storage #1Samsung 850 EVO 500GB SSD
    Storage #2Seagate® Desktop SSHD 4TB
    CPU CoolerNoctua NH-U14S
    CaseNZXT Phantom 820 Big Tower
    Power SupplyEVGA Supernova G2 850W
    Keyboard Steelseries Apex M800
    Mouse Steelseries Rival 700
    Headset Steelseries Sibera 800
    Mouse Pad Steelseries Dex
    OS Windows 10 Home

    Join Date
    Apr 2016
    Reputation
    10
    Posts
    15

    Steelseries Mouse and Keyboard, need to re-plug to get them working.

    Hello! First post and happy to be part of the famous ROG community

    I have a Steelseries Mouse (Wireless Sensei) and keyboard (Apex M800). I have to re-plug them sometime to get them to work.
    It is usually the keyboard that needs to be re-plugged but it happens with the mouse as well. I have contacted Steelseries and they
    just want to RMA the keyboard and mouse, they do not want to find any solutions with this problem. I borrowed them to a friend
    where they worked without a single problem on his computer.

    thats why I hope I can get some help from ROG as the problem can be something with the motherboard. I have changed the settings in
    Device Manager and ticked of all ''Let the computer turn this of..'' on all USB-Devices linked to the keyboard and mouse.

    Any solutions or ideas I can try out?

    Specifications

    Chassi NZXT H440W
    Motherboard Asus ROG Maximus VIII Hero
    Graphic Card Nvidia Geforce 980TI Asus
    Processor Intel Core i7-6700K Skylake
    RAM Vengeance DRR4 2133Mhz 16GB
    SSD Samsung 850 500GB
    HDD 1 Seagate 4TB SSHD
    HDD 2 Seagate 2TB
    OS Windows 10

  2. #2
    ROG Enthusiast Array Eric_F PC Specs
    Eric_F PC Specs
    MotherboardMaximus VIII Hero
    ProcessorCore I7 6700K - 4.9GHz OC
    Memory (part number)G.Skill F4-3000C15D-16GVR 16GB (8x2) DDR4-3000
    Graphics Card #1EVGA GTX 1080 FTW2 1721/1860MHz
    Sound CardOnboard Realtek/ROG SupremeFX
    MonitorDell UltraSharp 1908WFP 19" Widescreen 1440x900 60/75Hz
    Storage #11TB Western Digital Black WD1003FZEX 7500RPM 64MB Cache 6 Gb/s SATA
    Storage #22TB Western Digital Black WD2003FZEX 7500RPM 64MB Cache 6 Gb/s
    CPU CoolerCorsair H80i v2
    CaseAntec Nine Hundred (w/ USB 3)
    Power SupplyAntec Edge 650 80+ Gold
    Keyboard Steelseries Apex
    Mouse Steelseries Rival
    Mouse Pad Tandy gray mousepad from the '90s!
    Headset/Speakers AKG K240M studio headphones & Adcom GTP-450 preamp on line-outs
    OS Windows 10 Pro
    Network RouterAsus RT-AC3200
    Eric_F's Avatar
    Join Date
    Feb 2016
    Reputation
    34
    Posts
    56

    I also have a Steelseries keyboard and mouse -- Original Apex and Rival. I don't think this problem is specific to ROG boards -- I've had similar issues with the same two devices plugged into a Mac Mini (late 2009 model) and a Z61 ThinkPad.

    On the Mac Mini, the mouse would sometimes fail to be detected at wake from sleep but the keyboard was fine.

    On the ThinkPad, the keyboard wouldn't fully illuminate during POST (only the main keyboard and the numpad section, none of the F-keys, and then would be fine once Windows booted.

    On my Maximus VIII Hero, usually the keyboard and mouse will be fine (and always are fine in BIOS screens) but once the USB bus resets before booting Windows, sometimes the keyboard will come up only partially illuminated again. Sometimes re-plugging it will fix it, other times I must shut down completely and restart. Also, the mouse will wake the PC from sleep fine, but using the keyboard will cause it to be dropped completely.

    So on every computer I've connected these two, there have been various issues with how they interact with USB. I tend to think that Steelseries still needs to work out a few issues in their firmware. Perhaps someone's discovered a useful tweak in the Asus BIOS that might help USB detection and behavior?

    I'd like to try re-flashing the keyboard's BIOS, but all I've encountered is auto-updaters in a few of the driver updates, and once it's done flashing, there doesn't seem to be any reset/re-flash options. Overall, I like this keyboard and mouse a lot, but I'd love to see a more robust utility for managing the firmware.

    If there are any other Steelseries users out there with more ideas, it would be great to try a little brainstorming.

  3. #3
    ROG Enthusiast Array
    Join Date
    Sep 2012
    Reputation
    11
    Posts
    49

    I used to to use the Original APEX RGB until I upgraded from my old AMD Sabertooth 990FX R 2.0 to a new I5 6600k Skylake. My Apex worked totally fine on my 990FX system. However once I was up and runninng on the z170-A motherboard it would cut out, aka the keys would now longer respond but the lights remain lit. After much reserch I determined it was an issue with the new USB controller on the Z170 and legacy built in cntroller that steelseries uses. I reported it many times, as did many other. There is no known fix for this issue and it is not limited to just steelseries after much posting on web. It is the new usb vs the legacy usb. I tried every USB port, disabling ports, disabling lan controller, changed USB bios setting to everything possible. When it would happen I had to unplug/re plug the keyboard to regain functionality. I reverted my APEX firmeware to many previous versions to no avail. MY conclusion was either deal with it or replace it. Dealing with it was a no go due to not being able to game with it. So I got a Corsair K70 as a replacement. Also I I have since rebuilt the old Sabertooth 990FX for my partner and use the Steelseries Apex keyboard on it with no issue

  4. #4
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,254

    Legacy USB devices cause conflicts on the Z170 platform. If you're experiencing this problem, go and look for a firmware update from the manufacturer.

  5. #5
    ROG Enthusiast Array Eric_F PC Specs
    Eric_F PC Specs
    MotherboardMaximus VIII Hero
    ProcessorCore I7 6700K - 4.9GHz OC
    Memory (part number)G.Skill F4-3000C15D-16GVR 16GB (8x2) DDR4-3000
    Graphics Card #1EVGA GTX 1080 FTW2 1721/1860MHz
    Sound CardOnboard Realtek/ROG SupremeFX
    MonitorDell UltraSharp 1908WFP 19" Widescreen 1440x900 60/75Hz
    Storage #11TB Western Digital Black WD1003FZEX 7500RPM 64MB Cache 6 Gb/s SATA
    Storage #22TB Western Digital Black WD2003FZEX 7500RPM 64MB Cache 6 Gb/s
    CPU CoolerCorsair H80i v2
    CaseAntec Nine Hundred (w/ USB 3)
    Power SupplyAntec Edge 650 80+ Gold
    Keyboard Steelseries Apex
    Mouse Steelseries Rival
    Mouse Pad Tandy gray mousepad from the '90s!
    Headset/Speakers AKG K240M studio headphones & Adcom GTP-450 preamp on line-outs
    OS Windows 10 Pro
    Network RouterAsus RT-AC3200
    Eric_F's Avatar
    Join Date
    Feb 2016
    Reputation
    34
    Posts
    56

    Well, I'm running the latest BIOS (1601) for the M8H, and just took yesterday's Win10 cumulative update (KB3147458) which is supposed to address some USB issues among others. So far, the keyboard has come up perfectly across several reboots. If nothing else, it might be minimized by fixing some Windows bugs. I still think the Steelseries firmware might need more tweaking for Win10, and what I'd really love would be away to perform the effect of a CMOS reset-to-default on the Steelseries hardware.

    Also, I keep my keyboard and mouse plugged into the USB2 ports on the top group of ports. I know the board has some limitations on legacy USB support on the USB3 controller. That shouldn't affect the USB2 ports, though. I keep my keyboard, mouse, joystick, and USB2 hub for older devices connected to the USB2 ports only to avoid potential legacy issues. For anyone else having issues with the Steelseries hardware, it might be worth making sure they're not on the USB3 or 3.1 ports.
    Motherboard: Maximus VIII Hero
    Processor: I7 6700K - 4.9GHz OC
    CPU Cooler: Corsair H80i v2
    Memory: G.Skill DDR4-3000 16GB
    Graphics: EVGA GTX 1080 FTW2 1721/1860MHz
    Storage #1: 1TB Western Digital Black
    Storage #2: 2TB Western Digital Black
    Case: Antec Nine Hundred
    Power Supply: Antec Edge 650 80+ Gold
    OS: Windows 10 Pro

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •