Results 1 to 7 of 7
  1. #1
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    18

    ROG Front Panel. Clock problem

    I have the ROG Front Panel. First I had installed with my old Z87 system (Z87 Maximus VI Hero). Everything was ok.

    Since January 2016 build a new Z170 system with Z170 Maximus VIII Hero. The clock of the Rog panel didn't work. Only show -:-.

    There are any compatibility problem with this motherboard or the panel has problem ?

  2. #2
    ROG Guru: Yellow Belt Array Code_Frenzy PC Specs
    Code_Frenzy PC Specs
    MotherboardMaximus VIII Hero Alpha
    Processori7-6700k
    Memory (part number)LPX 3000MHz DDR4 (CMK16GX4M2B3000C15)
    Graphics Card #1Zotac GTX 980ti AMP!
    Storage #1(OS) Samsung SM951 256GB NVMe
    Storage #2(Data) SanDisk Ultra II 960GB SSD
    CPU CoolerXSPC Raystorm Pro with custom loop
    CasePhanteks Enthoo Luxe
    Power SupplyCorsair 1200W (Hx1200i)
    OS Windows 10 Pro
    Accessory #1 XSPC Daul bay pump/res, EX420 + RX240 rads
    Accessory #2 ROG Front Base

    Join Date
    Feb 2016
    Reputation
    12
    Posts
    152

    Have you flashed the Panel with V48 Firmware?
    For Z170 you should have installed Windows driver version 1.01.17 and firmware V48 on the Panel.

  3. #3
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    18

    How can see the firmware had already the panel and how update the latest ?

  4. #4
    ROG Guru: Yellow Belt Array Code_Frenzy PC Specs
    Code_Frenzy PC Specs
    MotherboardMaximus VIII Hero Alpha
    Processori7-6700k
    Memory (part number)LPX 3000MHz DDR4 (CMK16GX4M2B3000C15)
    Graphics Card #1Zotac GTX 980ti AMP!
    Storage #1(OS) Samsung SM951 256GB NVMe
    Storage #2(Data) SanDisk Ultra II 960GB SSD
    CPU CoolerXSPC Raystorm Pro with custom loop
    CasePhanteks Enthoo Luxe
    Power SupplyCorsair 1200W (Hx1200i)
    OS Windows 10 Pro
    Accessory #1 XSPC Daul bay pump/res, EX420 + RX240 rads
    Accessory #2 ROG Front Base

    Join Date
    Feb 2016
    Reputation
    12
    Posts
    152

    I don't know which operating system your using so can't link directly to the correct file, but the selection page can be found here... https://www.asus.com/uk/Motherboard-...Desk_Download/
    Choose your OS from the drop down list and download the latest driver.
    Extract to a folder of your choice and open.
    Run the Asus Setup executable to install the Windows driver.
    Next open the FBFW folder that is also contained in the same place.
    Run the "ROG FRONT BASE" executable.
    Click the file browse button "..."
    Select the firmware file FB035Exv48.H00" (if installing version 48!)
    Click the "Start" button and let it do its thing.
    That should be it.

    You can check what version of Firmware you are currently running by shutting down the PC, keep power supplied to the motherboard though. Once fully shutdown, press and hold the Front Base select knob for a good 5 seconds. The currently installed firmware version will be displayed in the top righthand corner of the display.

  5. #5
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    18

    Previous version 4.4. I did everything as you write. But the result it's the same. The clock don't work.

  6. #6
    ROG Guru: Yellow Belt Array Code_Frenzy PC Specs
    Code_Frenzy PC Specs
    MotherboardMaximus VIII Hero Alpha
    Processori7-6700k
    Memory (part number)LPX 3000MHz DDR4 (CMK16GX4M2B3000C15)
    Graphics Card #1Zotac GTX 980ti AMP!
    Storage #1(OS) Samsung SM951 256GB NVMe
    Storage #2(Data) SanDisk Ultra II 960GB SSD
    CPU CoolerXSPC Raystorm Pro with custom loop
    CasePhanteks Enthoo Luxe
    Power SupplyCorsair 1200W (Hx1200i)
    OS Windows 10 Pro
    Accessory #1 XSPC Daul bay pump/res, EX420 + RX240 rads
    Accessory #2 ROG Front Base

    Join Date
    Feb 2016
    Reputation
    12
    Posts
    152

    Have you updated the BIOS?
    You could also try the solution posted here... https://rog.asus.com/forum/showthrea...ght=Front+base

  7. #7
    ROG Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    18

    Yes the BIOS it's the last 1601

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •