Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
  1. #11
    ROG Guru: Blue Belt Array Gps3dx PC Specs
    Gps3dx PC Specs
    Laptop (Model)Current: G751JT | Retired: G55VW, G51JX
    MotherboardInc M.2 slot
    Storage #1Samsungs EVO 850 128GB
    Storage #21TB HGST Travelstar 7K1000 (HTS721010A9E630)
    CPU CoolerMother Nature & Thermodynamics laws
    Mouse Logitech MX 518
    Headset/Speakers Logitech T6060
    OS Cleaned installed Windows 10 HOME x64
    Accessory #1 Leap Motion

    Join Date
    Feb 2015
    Reputation
    71
    Posts
    785

    Exclamation

    Quote Originally Posted by hexaae View Post
    https://forums.lenovo.com/t5/Lenovo-.../1374237#M5172
    Look at the pics... The difference seems just the Intel eXtensible driver in the place of the xHCI compliant one...
    Maybe forcing the Intel eXtensible will fix the port error...
    @hexaae m8... placing intel's driver instead of the default MS XHCI controller driver, AFAIK, will not effect these "unknown device".
    You shuold disconnect any USB device & external hubs and check if this "unknown device" exist.
    if it go away after that ->then one of your USB devices external to the G751 is the cause.
    Otherwise, continue to read this post.
    Quote Originally Posted by diogogmaio View Post
    Can you test? If it is the solution we can make a new sticky guide. Since Windows 10 we have this issue.
    I don't have my g751jy with me right now.
    Can you please express the need for new thread ? which theme ? why should it be 'sticky' ?
    I really don't understand why as there are already many threads with many similar topic like the USB issues/driver & clean Windows installation & drivers such as the following threads/posts: HERE, HERE, HERE, HERE, HERE. ( Please view them all ).
    A simple google search will return many of these posts and a possible solution.

    Now, because of its relevance i'll quote myself from one of the links above.
    Quote Originally Posted by Gps3dx View Post
    I can report that BIOS reflashing solve the odd appearance of "Unknown USB Device (Device Failed Enumeration)" under the USB tree in Device manager of my Windows 10 home ed on my G751JT.
    reflashing of the SAME bios version, solve it, so now I don't got this "Unknown USB Device" anymore.
    Remember that reinstallation of same bios version requires that you run WinFlash app with special switch as follows: WinFlash.exe /nodate
    Thus, please update or reinstall same version of your BIOS, then report back if that "unknown device" have "disappeared".

    My guess is that "unknown device" on "port 15"(not sure it must be that number) can appears when you either:
    • Perform windows update - [ NOTE: on win10 home ed' it is being done automatically, unless you do something
      about it like HERE under part 4]
    • install "Asus USB 3.0 boost" from the "AI Suite III" or any other component from "AI Suite III"
    • (what I think really causing it) messing up with USB's tree ( in device manager ) drivers ( updating/replacing XHCI controller, USB root hub, etc... )

    I got an "unknown port" after either one of these cases, reflashing same bios version make it go away. ( on my G751JT non G-sync )

    now... after you try it out... Can you please tell me if a new thread is still necessary ?

  2. #12
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013
    Reputation
    144
    Posts
    3,855

    I agree with you on one count, it doesnt need to be a sticky. If I was admin or even Mod on this forum most of the current stickies would be gone. When you have that many it makes the point of making a topic a sticky a moot point. From what I see, less that 5 would still be there. Mods actually created more of a mess for no reason themselves. There should be one sticky on useful threads then broken down into individual posts for the models instead of 7 different stickies. When half the page is stickies its far too many!

  3. #13
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    650

    Quote Originally Posted by Gps3dx View Post
    Now, because of its relevance i'll quote myself from one of the links above.

    Quote Originally Posted by Gps3dx View Post
    I can report that BIOS reflashing solve the odd appearance of "Unknown USB Device (Device Failed Enumeration)" under the USB tree in Device manager of my Windows 10 home ed on my G751JT.
    reflashing of the SAME bios version, solve it, so now I don't got this "Unknown USB Device" anymore.
    I got an "unknown port" after either one of these cases, reflashing same bios version make it go away. ( on my G751JT non G-sync )
    The only problem here is that it's a different case apparently: I DON'T have "Unknown USB Device (Device Failed Enumeration)" under Device Manager.
    I see that port 15 problem only from AIDA, HWiNFO, USBTreeView. My Device Manager reports no errors at all.
    Last edited by hexaae; 05-15-2016 at 08:36 AM.

  4. #14
    ROG Guru: Green Belt Array
    Join Date
    Mar 2015
    Reputation
    8
    Posts
    513

    Quote Originally Posted by hexaae View Post
    The only problem here is that it's a different case apparently: I DON'T have "Unknown USB Device (Device Failed Enumeration)" under Device Manager.
    I see that port 15 problem only from AIDA, HWiNFO, USBTreeView. My Device Manager reports no errors at all.
    first i see the port 15 error then i installed the usb3 driver with the modified inf.
    then i became the port 10 device unknown blabla...this is the macrokey driver.
    then deinstall and reinstall rogmacrokey now no issues on port 10&15 in hwinfo or devicemanager.

  5. #15
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    650

    Quote Originally Posted by warryabel View Post
    first i see the port 15 error then i installed the usb3 driver with the modified inf.
    then i became the port 10 device unknown blabla...this is the macrokey driver.
    then deinstall and reinstall rogmacrokey now no issues on port 10&15 in hwinfo or devicemanager.
    Thank you for this post... This makes sense, as I myself in the past noticed Rog Macrokey installs also a virtual keyboard + HID custom device.
    It's actually an external USB connected device to the system.
    Must be that indeed.
    Last edited by hexaae; 05-23-2016 at 09:43 AM.

  6. #16
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    650

    We were wrong, it's not ROG Macrokey the cause of USB port 15 unknown device...
    Uninstalled and still present.

  7. #17
    ROG Guru: Green Belt Array
    Join Date
    Mar 2015
    Reputation
    8
    Posts
    513

    what ever...my hope is somewhere and no light in sight with this crap! still no comment from asus,like on other issues...(soundpopping,vibrations of beezel near the touchpad,bad pasting etc.) cmon what will you say its all useless!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •