Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    5

    G751JY 2nd HDD not recognized problems

    Hello, i purchased a G751JY over a year and a half ago and now its started to present problems with the 2nd bay hard drive. It just stops recognizing there is an HDD installed in the computer, which is annoying because it happens in the most inconvenient times. To fix it I usually have to restart several times or I have to physically pull the hdd out of the port and plug it in again. It started a couple of months ago and its been getting more frequent since.

    Asus support obviously is clueless when you try to call or chat with them and they wanted to charge me 812CAD+tax for me to ship the laptop to their center so it could have a "revision", which is ludicrous.

    Anyone have an idea what could be the problem or suggestions where i could have it checked in Canada?

  2. #2
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,121

    Have your tried a different hard drive in that bay, It sound likely that the one you have is failing? you should run HD Diagnoses on it in the very least you will find that tool on the manufacture web site. If there is no hard drive problem you probably will have a hard ware issue.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  3. #3
    ROG Member Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Clintlgm View Post
    Have your tried a different hard drive in that bay, It sound likely that the one you have is failing? you should run HD Diagnoses on it in the very least you will find that tool on the manufacture web site. If there is no hard drive problem you probably will have a hard ware issue.
    yes, I have tried different hdd and the same problem.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •