Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    May 2016

    ROG Game First III Network Enhancer is causing performance issues with Overwatch

    Currently seeing an issue with GameFirst III and Overwatch.
    Basically while running Game First III with default settings performance will be poor and you can view users teleporting around during gameplay. Users may also view you teleporting around as they will have trouble engaging you during the game.

    1. Setup a PC that uses an ASUS RoG(Republic of Gaming) Motherboard that will support the Game First III software. MOBO tested was a Maximus IV Gene-Z
    2. Install all drivers, including the GameFirst III software.
    3. Restart the PC and ensure that the software is running at default values and switch the mode to Game. Overwatch should be labled with a "Normal" value.
    4. Install and run Overwatch
    5. Ensure that the Network indicators are enabled and load into a Quick Match.
    6. Once in the match, play as normal and keep an eye on the PNG, RTT, and IND.

    Additional Info: When switching the value to "High" or "Highest" the title performs as expected for the PC build and network stability is intact.
    Also, when in the "Optimized" mode, the network performance does not appear to be affected.

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Jun 2015

    Game First causing issues is nothing new, the usual recommendation is to uninstall it.

  3. #3
    ROG Member Array m33ts4k0z PC Specs
    m33ts4k0z PC Specs
    MotherboardASUS Prime B-365 Plus
    ProcessorIntel Core i7 8700K
    Memory (part number)Corsair Vengeance 32GB @ 3200MHz
    Graphics Card #1Gigabyte Aorus GTX 1080Ti
    Sound CardAsus ROG Xonar Phoebus Solo 7.1
    MonitorBenQ 32" BL3201PT 4K
    Storage #1Samsung NVMe SSD 950 PRO 512GB
    Storage #2Western Digital Black 1TB
    CPU CoolerCorsair Hydro H100X
    CaseFractal Design Define R5
    Power SupplyFractal Design Newton R3 1000W Platinum
    Keyboard Logitech G915 Lightspeed
    Mouse Logitech G502 Lightspeed
    Headset Sennheiser GSP 600
    Mouse Pad SteelSeries QcK Edge - Large
    OS Windows 10 Pro
    Network RouterASUS AC-88U w/ ASUS Merlin

    Join Date
    Nov 2014

    I didn't have this issue while I was downloading from Steam and playing Overwatch at the same time about an hour ago. Steam needs to be on normal and overwatch on highest priority. This is normal because GFIII's database isn't updated with this game so it doesn't "know" that its a game.

  4. #4
    ROG Guru: White Belt Array FalloutBoy PC Specs
    FalloutBoy PC Specs
    Laptop (Model)G751JY-T7042H
    MotherboardROG Zenith Extreme Alpha
    ProcessorAMD 2950X
    Memory (part number)Corsair CMW64GX4M4C3200C16W
    Graphics Card #1Aorus GTX 1080 Ti Extreme 11Gb
    Sound CardInbuilt
    MonitorViewsonic XG-2703-GS
    Storage #1Samsung 960 EVO 1 Tb
    Storage #2Raid 6 Array 8 x 4 Tb SAS III on a 9361-8i
    CPU CoolerNoctua NH-U14S TR4 Edition with two AF15s
    CaseXigmatek Elysium Super Tower
    Power SupplySilverstone Strider ST-1500
    Keyboard Hyper X Alloy Elite RGB
    Mouse Razor Chroma Deathadder
    Headset Hyper X Revolver S
    Mouse Pad Playmax
    Headset/Speakers Creative Labs 2.1
    OS Windows 10 Pro 64 Bit 1903
    Network RouterFritzbox 7490

    Join Date
    Jan 2013

    Exclamation O.K This is going to sound truely out there BUT

    I have a ROG Zenith Alpha with a 2950x I installed the game first drivers off of the supplied USB stick and then after reboot checked for an update - which there was, I applied the update and rebooted and thought nothing more of it barring the fact that I started having page resolving errors without any specific reason, the connection was good and my X399 Prime A was getting though first time.

    So I tried a restart at which point the boot cycle stopped at CPU 0D - when I looked this up it says "Reserved for future AMI SEC error codes".

    Confused I pulled the mains cable and waited 30 seconds, plugged back in and all booted up fine, so I tried another restart and again the boot cycle stopped at CPU 0D I pulled the mains again waited 30 seconds, plugged it back in and it came on first time. The only change I had made was the install and upgrade of the ROG First software and thus although it seemed highly illogical I uninstalled it.

    I have now done four successive restarts with no problem, put the computer to sleep with no problem, powered it on and powered it off - no problem could the ROG game first software cause this sort of issue it seems truly out there as it's only meant to optimize network traffic based on a user choice how the hell would it effect the CPU on a warm start?
    I truly believe that there are people on this planet who should voluntarily remove them selves from the gene pool.
    Maximus IV Extreme Z/16G/2600K, Rampage V Extreme Edition 10/32G/6900K, G751JY-T7042H
    Zenith Extreme Alpha/64G/2950x , X399 Prime A/32G/1900X
    Power Mad Mu ha ha ha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts