Results 1 to 8 of 8
  1. #1
    ROG Member Array
    Join Date
    May 2016
    Reputation
    10
    Posts
    6

    Updated OC Panel FW, LCD stopped working

    So i got my Rampage a week ago and loving it. I decided it was time to start overclocking the system and use the OC panel. I was browsing the forums and i found
    the thread about how to use it as well as a link to how to properly update the FW.
    So i disabled the xhci for USB in the BIOS and proceeded with the update in Windows. I install the ROG connect and the Front Driver which also began the FW update.
    The FW update completed without any issues but i noticed the Panels LCD had turned off. So i reboot my system but the panel stayed off. Pressing the On button on
    the LCD turns the back-light on only but no numbers come up.
    My system still detects the panel if i disconnect the USB connection and reconnect and i can still flash the FW to it. Ive done it twice to see if it was a FW glitch. But the
    LCD remains off. If i attempt to run ROG connect it displays an error " No device to connect to". But the Front Driver can still detect the connection and update.

    The internal LEDS in the PCB still light up. The little HDD flickers away. But im guessing its FW independent.

    Is there a link to the original or previous FW i cant seem to find one? Just in case theres a compatibility issue.

  2. #2
    ROG Guru: Orange Belt Array smokeintheeye PC Specs
    smokeintheeye PC Specs
    MotherboardRampage V Extreme (X99) Bios 3101
    ProcessorI7 5820K @ 4.6GHz @ 1.285v
    Memory (part number)Corsair Vengeance LPX XMP @ 2400MHz
    Graphics Card #1MSI R9-290 Gaming @ 1100/1375
    MonitorPhilips 4K BDM4065UC
    CPU CoolerSupr EVO X99 + 360 Rad + 1000ml Res + Swiftech MCP655
    CaseHAF X
    Power SupplyHX1000i
    Keyboard Logitech G910
    Mouse Logitech G502
    Mouse Pad Logitech G440
    OS Windows 10 pro 64bit
    Accessory #1 AMBI lighting
    smokeintheeye's Avatar
    Join Date
    Jan 2012
    Reputation
    14
    Posts
    279

    Did you flash the FW for the OC panel 1 or 2 (Not the front base) ? you need the ROG connect plus drivers on the pc with the panel. The ROG connect drivers are the ones you will have to use on a different pc to connect to the R5E, ie laptop. the R5E uses the OC panel 1. in bios keep usbs on smart auto.

    http://www.asus.com/Motherboard-Accessories/OC_Panel/


    Any Reputation is welcome. thanks

  3. #3
    ROG Member Array
    Join Date
    May 2016
    Reputation
    10
    Posts
    6

    What do you mean by OC Panel 1 or 2?
    The files I downloaded from ASUS are the ROG connect / ROG connect plus contain no FW updates just drivers for Windows.
    As far as im aware the Front Base contains the FW which is what i used to flash the panel with. (Well had no choice as the AsusSetup.exe started the flash automatically)
    It was only after the Front Base flash did the LCD stop working but i still have the USB connection to the device.
    But im unable to use ROG Connect as it states "The Connection is not Available". (Connect Plus has no exe files so im assuming it has some extra features that use dll hooks
    into the ROG Connect program)

  4. #4
    ROG Guru: Orange Belt Array smokeintheeye PC Specs
    smokeintheeye PC Specs
    MotherboardRampage V Extreme (X99) Bios 3101
    ProcessorI7 5820K @ 4.6GHz @ 1.285v
    Memory (part number)Corsair Vengeance LPX XMP @ 2400MHz
    Graphics Card #1MSI R9-290 Gaming @ 1100/1375
    MonitorPhilips 4K BDM4065UC
    CPU CoolerSupr EVO X99 + 360 Rad + 1000ml Res + Swiftech MCP655
    CaseHAF X
    Power SupplyHX1000i
    Keyboard Logitech G910
    Mouse Logitech G502
    Mouse Pad Logitech G440
    OS Windows 10 pro 64bit
    Accessory #1 AMBI lighting
    smokeintheeye's Avatar
    Join Date
    Jan 2012
    Reputation
    14
    Posts
    279

    you need the (ROG Connect plus driver) for the OC panel to work right. there are 2 different OC panels the rampage 5 comes with panel 1 so you will need the FW for that one ( in link above ) . you will need the FW update tool as well.

    so install the ROG Connect plus driver on your pc then reflash the FW for the OC panel 1.

    OC Panel Firmware Update Tool for V1.0.3.2.

    OC Panel Firmware 0603 for OC Panel

    ASUS ROG Connect Plus V1.00.30 for Windows 7/8/8.1/10 32bit & 64bit.

    hope that helps

    Edit: sorry forgot to say you might need the ASUS Probe II Sense Driver V1.0.1.0 as well.
    Last edited by smokeintheeye; 05-20-2016 at 11:32 AM.


    Any Reputation is welcome. thanks

  5. #5
    ROG Guru: Orange Belt Array smokeintheeye PC Specs
    smokeintheeye PC Specs
    MotherboardRampage V Extreme (X99) Bios 3101
    ProcessorI7 5820K @ 4.6GHz @ 1.285v
    Memory (part number)Corsair Vengeance LPX XMP @ 2400MHz
    Graphics Card #1MSI R9-290 Gaming @ 1100/1375
    MonitorPhilips 4K BDM4065UC
    CPU CoolerSupr EVO X99 + 360 Rad + 1000ml Res + Swiftech MCP655
    CaseHAF X
    Power SupplyHX1000i
    Keyboard Logitech G910
    Mouse Logitech G502
    Mouse Pad Logitech G440
    OS Windows 10 pro 64bit
    Accessory #1 AMBI lighting
    smokeintheeye's Avatar
    Join Date
    Jan 2012
    Reputation
    14
    Posts
    279

    Quote Originally Posted by Aus_Karlos View Post
    What do you mean by OC Panel 1 or 2?
    The files I downloaded from ASUS are the ROG connect / ROG connect plus contain no FW updates just drivers for Windows.
    As far as im aware the Front Base contains the FW which is what i used to flash the panel with. (Well had no choice as the AsusSetup.exe started the flash automatically)
    It was only after the Front Base flash did the LCD stop working but i still have the USB connection to the device.
    But im unable to use ROG Connect as it states "The Connection is not Available". (Connect Plus has no exe files so im assuming it has some extra features that use dll hooks
    into the ROG Connect program)
    sorry just reread your post are you using the front base or the OC panel? in your computer?

    OC panel
    Click image for larger version. 

Name:	P_setting_fff_1_90_end_500.jpg 
Views:	60 
Size:	29.2 KB 
ID:	57526

    Front Base
    Click image for larger version. 

Name:	P_setting_000_1_90_end_500.jpg 
Views:	61 
Size:	45.1 KB 
ID:	57527
    Last edited by smokeintheeye; 05-20-2016 at 11:48 AM.


    Any Reputation is welcome. thanks

  6. #6
    ROG Guru: Orange Belt Array smokeintheeye PC Specs
    smokeintheeye PC Specs
    MotherboardRampage V Extreme (X99) Bios 3101
    ProcessorI7 5820K @ 4.6GHz @ 1.285v
    Memory (part number)Corsair Vengeance LPX XMP @ 2400MHz
    Graphics Card #1MSI R9-290 Gaming @ 1100/1375
    MonitorPhilips 4K BDM4065UC
    CPU CoolerSupr EVO X99 + 360 Rad + 1000ml Res + Swiftech MCP655
    CaseHAF X
    Power SupplyHX1000i
    Keyboard Logitech G910
    Mouse Logitech G502
    Mouse Pad Logitech G440
    OS Windows 10 pro 64bit
    Accessory #1 AMBI lighting
    smokeintheeye's Avatar
    Join Date
    Jan 2012
    Reputation
    14
    Posts
    279

    If you have flashed the Rog front base FW on to the OC panel(1) all you need to do is reflash it with the OC panel FW and all will be working again.


    Any Reputation is welcome. thanks

  7. #7
    ROG Member Array
    Join Date
    May 2016
    Reputation
    10
    Posts
    6

    Well that clears up that issue, i didnt know that the Front Base was actually referring to a different device.
    It seems strange that ASUS will supply drivers on the Rampage download page for the Front Base when its not sold with the Rampage.
    And then dont actually supply the OC Panel FW on the Rampage download page when its sold as a package.
    As you can see its going to cause confusion. Lucky both OC panels seem to share a similar Programable Logic Controller otherwise flashing the FW could of been worse.

    Any thanks for the help and clarification.

  8. #8
    ROG Junior Member Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    2

    What version of windows were you running? I seem to have made the same mistake - running windows 10 and I can't figure out how to run the update tool any help would be great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •