Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    5

    Angry PG278Q RMA - The gloves are off

    I received my first monitor with a strange backglow, when the screen was dark you could see a white-ish glowing spot cover about half of the screen.
    I've never been able to take a clear picture of it but it looks extremely similar to what a different user has posted in the past: http://i.imgur.com/4KiFJ1S.png
    This was only visible under certain conditions and since i didn't feel like going through the RMA process back then i chose to accept it.
    That doesn't take away that it's absolutely ridiculous for a premium product to be having such an issue and makes one question Asus's quality control as these kind of reports are spread far and wide.

    No further issues for about 1,5 years.

    About 3 months ago i started noticing inconsistencies in the image, the right side of the screen showed a different looking image than the left side, text became blurry and the screen started flickering.
    Apparently a pretty common issue when you check out the forums.
    i.e.: https://rog.asus.com/forum/showthrea...uality-overall
    I have to add that apart from the mechanical defect, the monitor was in pristine condition.


    My first RMA and thus the 2nd monitor took about 7 weeks to arrive.
    I chose to pick it up at my local vendor as i wanted to avoid possible damage by having it sent through the mail.
    Customer service informed me that Asus had sent a refurbished model which raised some concerns for me but i accepted it, i was stupid enough to take it home without having it tested first.
    When i took it out of the box it was completely undamaged, the problem came with functioning, something this monitor didn't know how to do.
    I turned it on and was greeted with a "NO SIGNAL" error, it took me a day of troubleshooting to figure out that this monitor was broken as well.
    When you think about it, Asus sent me back a monitor that was more broken than the one i RMA'ed in the first place.
    Nice one!
    After bringing it back to my local vendor they had it tested at their technical department, they found the same issue, which bring us to the second RMA.


    Another 3 weeks go by.

    Today i went to pick up my 3rd monitor, as expected there was a problem straight away, even though Asus promised to send a completely new monitor, customer service informed me that they received another refurbished model.
    I didn't feel like getting tricked this time so even though the technical department told me it was fully functioning this time i asked them to take it out of the box.
    This is what i found: http://imgur.com/a/1kA3c
    It'll be a cold day in hell before i accept this hack and slash job for an RMA Asus.
    Obviously i had it sent back straight away.

    In total this whole process took nearly 3 months with more to come, all without any results whatsoever.
    I want to make very clear that for the price i paid, i expect a product in pristine condition and because of that i'll keep RMA'ing these monitors until i feel they live up to my expectations.
    No dead pixels, no more backglow, no more backlight bleeding, no more external or internal damage, the RMA's will keep coming until i receive a monitor that is perfect in every single way even if it's gonna take over a year to achieve that.
    If this is how Asus likes to treat it's customers then i'll be sure to spend my money elsewhere in the future.
    Last edited by Fatchicken; 11-22-2017 at 08:31 PM.

  2. #2
    ROG Enthusiast Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    36

    I would ask for a full refund of your original purchase price. If they keep sending you refurbished units, you aren't gonna get what you want and the refurbished units have a lower warranty window.

  3. #3
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    5

    It's a little more complicated than that, my local vendor doesn't do refunds after a certain amount of time (which i believe is no more than 30 days after purchase).
    I'll have to see how the upcoming RMA turns out, obviously i'm not expecting too much of it at this point.
    My next step will probably be to take this to social media (twitter, facebook, reddit, etc.), manufacturers have been known to suddenly respond once their shenanigans are called out in public.

  4. #4
    ROG Enthusiast Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    36

    That's frustrating and I can sympathize with your pain. I had a PG27AQ(The 4k monitor) for about 2 days when I returned it. It had a burned out pixel cluster and the lower left of the screen was yellow in color. I have also returned an X34 which had damage to it's anti-glare coating. At this point, I am waiting for the x34P to see if the new LG panels have better QC.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •