Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    1

    Asus ROG G74SX Shuts Off While Gaming.

    Hello everyone, I will try to be as clear as possible. Nothing but two days ago I decided to run a clean install of windows 7 ultimate 64 bits on the machine (was previously running windows 10) and ever since I made the change my computer shuts off while gaming, it doesnt give out any warning sign, it just shuts off and restarts. I checked the temperature log and the max was 72 ºC which is perfectly fine imo, im also not running heavy games that could overload the system or cause an overheat, Ive also been using the same power adapter that was working fine a week ago but now I really dont know what to do, it goes 30-40 minutes into any game and the laptop shuts off. I tried formatting all my hard drives and installing windows 10 back again, it did improve the performance but it keeps shutting off. I checked every driver on the Asus official website and everything is checked, either with or without the battery the notebook shuts off while playing ANY game. Taking it to the service could be something somewhat complicated since I live in Argentina and we dont have these machines over here, so if any of you could give me any suggestions to WHAT is causing this would be greatly appreciated, have a good day.
    Last edited by khryo; 08-02-2016 at 04:05 PM.

  2. #2
    ROG Enthusiast Array
    Join Date
    Jul 2016
    Reputation
    10
    Posts
    36

    Try downloading the ASUS notebook probe or CPU-z to check the processor temps. Make sure the exhuast vents are not blocked. Clean them out at least once a month with an air duster. Try using a laptop cooling pad to troubleshoot.

  3. #3
    ROG Enthusiast Array
    Join Date
    Apr 2016
    Reputation
    10
    Posts
    26

    having same issue with my G751JL, ever since i bought the laptop when im playing game or doing too many things together and my laptop reaches around 75 C, my laptop turns off without any warnings
    i've sent my laptop twice for RMA and nothing has changed, my only hope now is to find a and answer in this forums at this points.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •