Results 1 to 3 of 3

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    5

    Asus G75VW (670M) instant shut-down during GPU load

    People of the republic,
    my old G75VW is having some issues these days - It turned itself into a heavy e-book!
    (Continuous usage of non-GPU applications are no problem)


    Basically under any heavy GPU load (artificial or not) the thing instantly shuts itself down.

    - Temperature readings are fine, case is not particularly hot at any point.
    - Drivers are the latest 368.81 on W10 x64 - I've heard you really should not use the newest for that GPU, but it was all fine until a week ago.
    - Average room temperature 23C, 70% humidity.

    Is there anyone who had similar issues which they managed to fix the problem? I supposedly, think it's a hardware issue - but it would be great to check things out.


    I've on occasion dusted it out a couple of times, and some bubble-gum has started to become partially leaky on the GPU unit. Is the thermal paste the source of the problem?

    Also my unit has been under heavy transportation, at some point I had reconnect the HDD bay-reader due to a loose connector - about a year ago.

    If the GPU is faulty, can I purchase a 670M or maybe even the 670MX somewhere? (or maybe even the 660M...) (I really prefer the Fermi unit)
    (I can't go all in on a new notebook at this point)

    Sorry for the troubles,
    Raven.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •