Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
  1. #11
    ROG Guru: White Belt Array
    Join Date
    Apr 2012
    Reputation
    12
    Posts
    78

    I just updated from the Rampage V to the new 10th edition. I remember how long it took me to get my 3000mhz ram stable on the Rampage V. It was a battle for sure. Well with this new 10th Edition, I bought some Corsair 3400mhz ram. I went into the bios enable XMP and it booted straight into windows. Ran superPI 32 test and it also passed. Have to say, i'm loving this new board.

  2. #12
    ROG Guru: Brown Belt Array Vlada011 PC Specs
    Vlada011 PC Specs
    MotherboardRampage V E10 (BIOS 1903)
    ProcessorIntel®i7-5820K (4.5GHz 1.325V)
    Memory (part number)CMD16GX4M4A2666C15
    Graphics Card #1ASUS GTX1080Ti Poseidon
    Sound CardSound Blaster ZxR
    MonitorSamsung P2450H
    Storage #1Samsung 970 EVO PLUS 1TB
    Storage #2Samsung 850 EVO 1TB/WD Black 2TB
    CPU CoolerEK RGB Monoblock RVE10
    CaseLian Li PC-O11 WXC
    Power SupplyEVGA 1200 P2
    Keyboard Deck 87 Francium PRO - MX Brown DS PBT
    Mouse Logitech G900
    Mouse Pad Steeseries QCK
    Headset/Speakers CREATIVE T5900 5.1
    OS Windows 10 Pro x64 v1903
    Accessory #1 iPhone SE Space Grey
    Accessory #2 EK XRES D5 Revo 100 Glass PWM + CoolstreamPE 360
    Accessory #3 Noctua NF-A12x25 PWM x3 (radiator)
    Vlada011's Avatar
    Join Date
    Oct 2013
    Reputation
    20
    Posts
    1,470

    Quote Originally Posted by Craig View Post
    I just updated from the Rampage V to the new 10th edition. I remember how long it took me to get my 3000mhz ram stable on the Rampage V. It was a battle for sure. Well with this new 10th Edition, I bought some Corsair 3400mhz ram. I went into the bios enable XMP and it booted straight into windows. Ran superPI 32 test and it also passed. Have to say, i'm loving this new board.
    Yes but memory speed depend a lot from CPU IMC.
    I'm sad because ASUS didn't build so nice and first version, I couldn't wait any more for Black version.
    It's obvious better board and looking RVE experience of people many of them complain on different problems.
    I can't say that I didn't know, I saw a lot of problems and from beginning I didn't had feeling that she is reliable and stable board,
    but I had and CPU and memory and question was 1. Now RVE,
    2. some MSI or other high end X99 board or 3. delay X99 completely.
    Because before I build X99 I knew that I will go on some more expensive reliable board and I expect to RVE repeat same as R4E.
    And I payed i7-5820K so below price and that would be bad decision to gave up from X99.
    Last edited by Vlada011; 08-28-2016 at 07:04 AM.


  3. #13
    ROG Guru: Orange Belt Array vmanuelgm's Avatar
    Join Date
    Sep 2013
    Reputation
    22
    Posts
    274

    After one week with the new RV10, I have to say:

    1. The RV10 works at pciex 2.0 after formatting with a TitanP installed on pciex 16x 1.
    2. The socket in the RV10 makes my 6950x run hotter with the same parameters of my other RVE.
    3. One of the usb 3.1 ports at the back panel (red) stopped working.

    I dont know if it is a faulty unit or any RV10 will do the same in my rig. Opened an RMA to exchange the board. Meanwhile, my RVE is again in working flawlessly!!!

    Omega, 7980xe, G.Skill 3600, 2080Ti, SM951 256, 970 PRO, 860 EVO
    Intel 750, WD SN750 Black, 840 Pro, 2xSkyhawk 4TB, 7200.14, 207EBK
    EVGA T2 1600, Silverstone TJ11, Custom LC. @Acer Predator x34

  4. #14
    ROG Guru: Brown Belt Array Vlada011 PC Specs
    Vlada011 PC Specs
    MotherboardRampage V E10 (BIOS 1903)
    ProcessorIntel®i7-5820K (4.5GHz 1.325V)
    Memory (part number)CMD16GX4M4A2666C15
    Graphics Card #1ASUS GTX1080Ti Poseidon
    Sound CardSound Blaster ZxR
    MonitorSamsung P2450H
    Storage #1Samsung 970 EVO PLUS 1TB
    Storage #2Samsung 850 EVO 1TB/WD Black 2TB
    CPU CoolerEK RGB Monoblock RVE10
    CaseLian Li PC-O11 WXC
    Power SupplyEVGA 1200 P2
    Keyboard Deck 87 Francium PRO - MX Brown DS PBT
    Mouse Logitech G900
    Mouse Pad Steeseries QCK
    Headset/Speakers CREATIVE T5900 5.1
    OS Windows 10 Pro x64 v1903
    Accessory #1 iPhone SE Space Grey
    Accessory #2 EK XRES D5 Revo 100 Glass PWM + CoolstreamPE 360
    Accessory #3 Noctua NF-A12x25 PWM x3 (radiator)
    Vlada011's Avatar
    Join Date
    Oct 2013
    Reputation
    20
    Posts
    1,470

    I don't know for me these 3 boards with X99 chipset are nicest for me.

    1. Rampage V Edition 10TH
    2. Rampage V Extreme
    3. MSI X99 Titanium

    X99 Titanium have better features than RVE because it's newer, and look nice, E-ATX size, real high end board for Intel Xtreme but can't compare with Rampage Black.

    Are you sure that your i7-6950X is hotter on RV10TH than RVE?
    Maybe you didn't notice before. It's possible to CPU run hotter on different motherboards but difference is maybe 2-3C.
    Last edited by Vlada011; 08-29-2016 at 10:46 AM.


  5. #15
    ROG Guru: Orange Belt Array vmanuelgm's Avatar
    Join Date
    Sep 2013
    Reputation
    22
    Posts
    274

    Quote Originally Posted by Vlada011 View Post
    I don't know for me these 3 boards with X99 chipset are nicest for me.

    1. Rampage V Edition 10TH
    2. Rampage V Extreme
    3. MSI X99 Titanium

    X99 Titanium have better features than RVE because it's newer, and look nice, E-ATX size, real high end board for Intel Xtreme but can't compare with Rampage Black.

    Are you sure that your i7-6950X is hotter on RV10TH than RVE?
    Maybe you didn't notice before. It's possible to CPU run hotter on different motherboards but difference is maybe 2-3C.
    Completely sure cos I tried different stress tests during the week.

    As I said, maybe the RV10 was faulty!!!


    Forgot to mention that when using flashback the bios led didn't blink, and according to manual it was supposed to. The flash button did blink.
    Last edited by vmanuelgm; 08-29-2016 at 11:29 AM.
    Omega, 7980xe, G.Skill 3600, 2080Ti, SM951 256, 970 PRO, 860 EVO
    Intel 750, WD SN750 Black, 840 Pro, 2xSkyhawk 4TB, 7200.14, 207EBK
    EVGA T2 1600, Silverstone TJ11, Custom LC. @Acer Predator x34

  6. #16
    ROG 師傅 Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH EXTREME
    ProcessorTHREADRIPPER 1920X
    Memory (part number)F4-3200C14Q-32GVK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Phobya Bench...let it all hang out man!
    Power SupplySeasonic SS-1200XP3
    Keyboard Logitech G810 or Fender Rhodes Electric Piano (MKI 73)
    Mouse G502 or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    498
    Posts
    13,501

    Quote Originally Posted by vmanuelgm View Post
    Forgot to mention that when using flashback the bios led didn't blink, and according to manual it was supposed to. The flash button did blink.
    Same on mine...since I'm on a bench I wish the BIOS light did flash...miss that functionality...have to lean over to watch light on rog connect button...

  7. #17
    ROG Guru: Brown Belt Array Vlada011 PC Specs
    Vlada011 PC Specs
    MotherboardRampage V E10 (BIOS 1903)
    ProcessorIntel®i7-5820K (4.5GHz 1.325V)
    Memory (part number)CMD16GX4M4A2666C15
    Graphics Card #1ASUS GTX1080Ti Poseidon
    Sound CardSound Blaster ZxR
    MonitorSamsung P2450H
    Storage #1Samsung 970 EVO PLUS 1TB
    Storage #2Samsung 850 EVO 1TB/WD Black 2TB
    CPU CoolerEK RGB Monoblock RVE10
    CaseLian Li PC-O11 WXC
    Power SupplyEVGA 1200 P2
    Keyboard Deck 87 Francium PRO - MX Brown DS PBT
    Mouse Logitech G900
    Mouse Pad Steeseries QCK
    Headset/Speakers CREATIVE T5900 5.1
    OS Windows 10 Pro x64 v1903
    Accessory #1 iPhone SE Space Grey
    Accessory #2 EK XRES D5 Revo 100 Glass PWM + CoolstreamPE 360
    Accessory #3 Noctua NF-A12x25 PWM x3 (radiator)
    Vlada011's Avatar
    Join Date
    Oct 2013
    Reputation
    20
    Posts
    1,470

    Motherboard market have more RMA than all other hardware together.


  8. #18
    ROG Guru: Gold Belt Array Menthol PC Specs
    Menthol PC Specs
    MotherboardM 10 Apex / XI gene
    Processor8700K / 9900K
    Memory (part number)2x8 Gskill Trident Z 4266/2x2x8 Gskill Trident Z 4500
    Graphics Card #1RTX 2080ti / GTX 1060
    Sound CardSoundBlaster Ae5 / Onboard
    MonitorBENQ 32" 4K
    Storage #1Intel 900p 480GB/Samsung 960 Pro 1TB
    Storage #2Intel 750 1.2TB/Plextor 1 TB 2X 950 Pro
    CPU CoolerCorsair H150i AIO / H1110i
    CaseCorsair 740 ? Lian Li Air
    Power SupplyCorsair AX 1200i / AX 1200i
    Keyboard Corsair
    Mouse ASUS Strix
    Headset HyperX Cloud Alpha
    Mouse Pad ASUS
    Headset/Speakers Logitech Z906
    OS 10 X64 Pro
    Network RouterVerizon Fios
    Accessory #1 Intel Wifi BT pcie card
    Accessory #2 Red Bull
    Accessory #3 English Breakfast Tea
    Menthol's Avatar
    Join Date
    Jan 2012
    Reputation
    241
    Posts
    4,548

    Quote Originally Posted by Arne Saknussemm View Post
    Same on mine...since I'm on a bench I wish the BIOS light did flash...miss that functionality...have to lean over to watch light on rog connect button...
    Is this on the RVE 10? I know of one person who had a bad flash using the Flashback method on this board, but he said he recovered his bios by cross flashing with the second bios so I used EZ-Flash within the bios to flash on this board as a precautionary method

  9. #19
    ROG Guru: Orange Belt Array vmanuelgm's Avatar
    Join Date
    Sep 2013
    Reputation
    22
    Posts
    274

    Quote Originally Posted by Menthol View Post
    Is this on the RVE 10? I know of one person who had a bad flash using the Flashback method on this board, but he said he recovered his bios by cross flashing with the second bios so I used EZ-Flash within the bios to flash on this board as a precautionary method
    There is no option in RV10 bios to copy one bios to another, like in RVE...
    Omega, 7980xe, G.Skill 3600, 2080Ti, SM951 256, 970 PRO, 860 EVO
    Intel 750, WD SN750 Black, 840 Pro, 2xSkyhawk 4TB, 7200.14, 207EBK
    EVGA T2 1600, Silverstone TJ11, Custom LC. @Acer Predator x34

  10. #20
    ROG 師傅 Array Arne Saknussemm PC Specs
    Arne Saknussemm PC Specs
    Laptop (Model)Laptop?...No way! (Model?...Jun Amaki...yes way!)
    MotherboardROG ZENITH EXTREME
    ProcessorTHREADRIPPER 1920X
    Memory (part number)F4-3200C14Q-32GVK
    Graphics Card #1GTX Titan X
    Graphics Card #2SLI is dead to me
    Graphics Card #3Tri SLI is even dead to Nvidia
    Graphics Card #4Quad SLI is dead to everybody especially my credit card
    Sound CardXonar Essence STX
    MonitorASUS ROG Swift PG279Q
    Storage #1Samsung 950 PRO
    Storage #22x OCZ VERTEX 3/2x WD Caviar Black 500GB / 2x WD RED 2TB
    CPU CoolerCustom Loop: Dual D5s, Dual Alphacool Monsta 480s, XSPC Raystorm Neo TR4, EK TitanX WaterBlock
    CaseNope!...Phobya Bench...let it all hang out man!
    Power SupplySeasonic SS-1200XP3
    Keyboard Logitech G810 or Fender Rhodes Electric Piano (MKI 73)
    Mouse G502 or Speedy Gonzalez...not Mickey...don't do Disney!
    Headset ...firmly on neck
    Mouse Pad Mouse don't got his own pad man...lives with me
    Headset/Speakers Edifier Spinnaker...or you mean the speakers in my head...man too many voices to name them all
    OS Win XP, 7, 8, 8.1 and Windows 10 Spyware Edition
    Network Router56k modem
    Accessory #1 Umm...nice tie?
    Accessory #2 Err...belt?
    Accessory #3 3 accessories?! I'm not a girl!!
    Arne Saknussemm's Avatar
    Join Date
    Apr 2012
    Reputation
    498
    Posts
    13,501

    Quote Originally Posted by Menthol View Post
    Is this on the RVE 10? I know of one person who had a bad flash using the Flashback method on this board, but he said he recovered his bios by cross flashing with the second bios so I used EZ-Flash within the bios to flash on this board as a precautionary method
    The BIOS flash itself went well...just the orange light by the chip didn't do the normal slow to quick flashing while it did it...

    Maybe keeping with the black edition thing...or they dont want competition for Aura

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •