Results 1 to 5 of 5
  1. #1
    ROG Member Array AngryAce PC Specs
    AngryAce PC Specs
    Laptop (Model)Sager 9170
    MotherboardAsus Maximus XI Formula
    ProcessorIntel i9-9900-K
    Memory (part number)Corsair 3200mhz SE Blackout
    Graphics Card #1eVGA GTX 1080Ti HydroCopper SC2
    Sound CardSound Blaster AE-7
    MonitorAsus ROG 34" Ultra-Wide
    Storage #1Sabrent Rocket 2TB NVME
    CPU CoolerCorsair XC7
    CaseLian Li Dynamic
    Power SupplyeVGA SuperNOVA 1000 P2
    Keyboard Razer Blackwidow X Chroma
    Mouse Razer Mamba Hyperflux
    Headset Sennheiser Game One
    Mouse Pad Razer Hyperflux
    OS Windows 10 Pro 64

    Join Date
    Aug 2016
    Reputation
    10
    Posts
    24

    To return or not return, that is the question.

    I am the owner of a new Rampage Edition 10. I didn't notice any issues with the board during bench testing and it works great with my 2x 32gb Corsair Vengeance LED kits. After getting it installed into my new case and getting everything buttoned up, I discovered LAN 2 (bottom port) doesn't appear to be working. It looks to be the 1211-AT controller. Both LAN devices are enabled in the bios but only the 1218-V controller shows in the device manager. If I plug a LAN cable into the port, it is dead, no lights or no internet connection. So unless there is something I am not aware of that needs to be done to get it working, it is dead.

    So, do I return a great running board over a LAN port I won't use since I use one anyway or do I let my slight OCD take over and return the board since it will bug me knowing it doesn't work....???

  2. #2
    ROG Guru: Brown Belt Array Vlada011 PC Specs
    Vlada011 PC Specs
    MotherboardRampage V E10 (BIOS 1903)
    ProcessorIntel®i7-5820K (4.5GHz 1.325V)
    Memory (part number)CMD16GX4M4A2666C15
    Graphics Card #1ASUS GTX1080Ti Poseidon
    Sound CardSound Blaster ZxR
    MonitorSamsung P2450H
    Storage #1Samsung 970 EVO PLUS 1TB
    Storage #2Samsung 850 EVO 1TB/WD Black 2TB
    CPU CoolerEK RGB Monoblock RVE10
    CaseLian Li PC-O11 WXC
    Power SupplyEVGA 1200 P2
    Keyboard Deck 87 Francium PRO - MX Brown DS PBT
    Mouse Logitech G900
    Mouse Pad Steeseries QCK
    Headset/Speakers CREATIVE T5900 5.1
    OS Windows 10 Pro x64 v1903
    Accessory #1 iPhone SE Space Grey
    Accessory #2 EK XRES D5 Revo 100 Glass PWM + CoolstreamPE 360
    Accessory #3 Noctua NF-A12x25 PWM x3 (radiator)
    Vlada011's Avatar
    Join Date
    Oct 2013
    Reputation
    21
    Posts
    1,475

    If everything work and you set all settings as you like I would not return. I would return if some important USB controller not work completely and several ports not work or some bigger things.
    Anyway Rampage V Extreme have only one Port and that was risky. Now you are in same situation. I know ... No problem not exist but if one more die than you will have problem.
    Than you need to move Sound in x4 slot and LAN Card in x1. Pay attention and always before storm disable one PC on PSU switch. and router.

    Sometimes hardware with similar small problem work excellent years without problems.
    Who knows maybe one day when you enter in Device Manager recognize and him.
    Last edited by Vlada011; 08-25-2016 at 04:33 AM.


  3. #3
    ROG Guru: Brown Belt Array Vlada011 PC Specs
    Vlada011 PC Specs
    MotherboardRampage V E10 (BIOS 1903)
    ProcessorIntel®i7-5820K (4.5GHz 1.325V)
    Memory (part number)CMD16GX4M4A2666C15
    Graphics Card #1ASUS GTX1080Ti Poseidon
    Sound CardSound Blaster ZxR
    MonitorSamsung P2450H
    Storage #1Samsung 970 EVO PLUS 1TB
    Storage #2Samsung 850 EVO 1TB/WD Black 2TB
    CPU CoolerEK RGB Monoblock RVE10
    CaseLian Li PC-O11 WXC
    Power SupplyEVGA 1200 P2
    Keyboard Deck 87 Francium PRO - MX Brown DS PBT
    Mouse Logitech G900
    Mouse Pad Steeseries QCK
    Headset/Speakers CREATIVE T5900 5.1
    OS Windows 10 Pro x64 v1903
    Accessory #1 iPhone SE Space Grey
    Accessory #2 EK XRES D5 Revo 100 Glass PWM + CoolstreamPE 360
    Accessory #3 Noctua NF-A12x25 PWM x3 (radiator)
    Vlada011's Avatar
    Join Date
    Oct 2013
    Reputation
    21
    Posts
    1,475

    You have one more option usefull on RVE10 if you have CPU with 40 lanes.
    Even if both port die, you can move sound card in PCI-Ex1 and install ROG 10G Express card in x4 slot.
    Probably is your local ASUS Office capable to find. That's much better than onboard Ports but need 40 lanes CPU.
    It's very smart decision to go with two different small slots, you can use Intel 750 or some other device.
    Most important is to board CPU/RAM are stable and capable to pull max from them.


  4. #4
    ROG Guru: White Belt Array Catalonia PC Specs
    Catalonia PC Specs
    MotherboardAsus Rampage V Eddition 10
    Processori7 6850k Broadwell-e @ 4.3GHz
    Memory (part number)G.Skill Trident Z DDR4 3200MHz CL14 32GB 4x8GB
    Graphics Card #1Asus Strix 1080 Ti OC
    MonitorAsus ROG Swift PG279Q 165Hz G-Sync IPS
    Storage #1Samsung SM961 M.2 512GB NVME
    Storage #23TB WD RED
    CPU CoolerCorsair H150i PRO
    CaseCorsair 780T Black
    Power SupplyCorsair AX1600i
    Keyboard Corsair K95 Platinum
    Mouse Logitech G903
    Headset Audio Technica DSR9BT
    Mouse Pad Corsair MM800 Polaris RGB
    OS W10
    Network RouterAsus GT-AC5300

    Join Date
    Sep 2015
    Reputation
    10
    Posts
    92

    Quote Originally Posted by AngryAce View Post
    I am the owner of a new Rampage Edition 10. I didn't notice any issues with the board during bench testing and it works great with my 2x 32gb Corsair Vengeance LED kits. After getting it installed into my new case and getting everything buttoned up, I discovered LAN 2 (bottom port) doesn't appear to be working. It looks to be the 1211-AT controller. Both LAN devices are enabled in the bios but only the 1218-V controller shows in the device manager. If I plug a LAN cable into the port, it is dead, no lights or no internet connection. So unless there is something I am not aware of that needs to be done to get it working, it is dead.

    So, do I return a great running board over a LAN port I won't use since I use one anyway or do I let my slight OCD take over and return the board since it will bug me knowing it doesn't work....???

    I would definitely return the MB. You've paid a crazy amount of money for a product that needs to work 100% no matter what. Even if you don't need that port now you never know what you can do with it in the future, or how can reduce the possible selling price of this MB if you ever think about selling it in the future.

    Definitely yes, get a new one 100% operational.

  5. #5
    ROG Member Array AngryAce PC Specs
    AngryAce PC Specs
    Laptop (Model)Sager 9170
    MotherboardAsus Maximus XI Formula
    ProcessorIntel i9-9900-K
    Memory (part number)Corsair 3200mhz SE Blackout
    Graphics Card #1eVGA GTX 1080Ti HydroCopper SC2
    Sound CardSound Blaster AE-7
    MonitorAsus ROG 34" Ultra-Wide
    Storage #1Sabrent Rocket 2TB NVME
    CPU CoolerCorsair XC7
    CaseLian Li Dynamic
    Power SupplyeVGA SuperNOVA 1000 P2
    Keyboard Razer Blackwidow X Chroma
    Mouse Razer Mamba Hyperflux
    Headset Sennheiser Game One
    Mouse Pad Razer Hyperflux
    OS Windows 10 Pro 64

    Join Date
    Aug 2016
    Reputation
    10
    Posts
    24

    Burned!

    Quote Originally Posted by Catalonia View Post
    I would definitely return the MB. You've paid a crazy amount of money for a product that needs to work 100% no matter what. Even if you don't need that port now you never know what you can do with it in the future, or how can reduce the possible selling price of this MB if you ever think about selling it in the future.

    Definitely yes, get a new one 100% operational.
    Well, after thinking it over and having an intermittent detection issue with my storage drive in addition to the dead LAN port, I decided to return the board to Newegg for a new one. Was in stock so I overnighted it back to them and today, OUT OF STOCK! So now, I could be sitting weeks without a board...... Getting Angrier! If I didn't have bad luck, I wouldn't have any luck at all....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •