Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    2

    Question Uninstalling GameFirst III limits download speed

    I noticed something peculiar. I had pretty bad lag (from high ping) on Overwatch, did a bit of digging and found out GameFirst III is a potential culprit. I went ahead and uninstalled it and my latency (ping) went back to normal.

    However, I realized there's a rather arbitrary cap whilst downloading through browsers (Chrome, Firefox, IE are some I tried). Downloading games on Steam and Origin seem to be fine as I get my ISP's rated speed.

    I'm on Ethernet and I have a G752. I have another laptop with an ethernet jack and I tested it out, did a speed test and speeds were normal.

    It's evident while downloading anything through a web browser. I get 2.0 MB/s max during downloading. Should I try to reinstall my network drivers? It's kind of odd as I only have this issue on my ROG laptop. I used the same speed test on my Xbox One and the results were as expected.

    It's funny that I get better speeds with an app designed to limit network usage but lower when after I uninstalled it...

    Speedtest on my G752 (Ethernet)
    http://i.imgur.com/WXdpmUb.png

    Speedtest on my Xbox One (Ethernet)
    http://i.imgur.com/B0yGplu.jpg

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •