Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Sep 2016

    GL752VW-DH74 Slow Wifi on Wireless AC

    Issue: My wifi is throttled to 54 Mbs speed (Wireless G Speed)

    GL752VW-DH74 with Intel Wireless AC 7265 (Driver Version, Date 7/24/2016)

    Just got this new ROG notebook. Love it, but the wifi is throttled for some reason.
    I have updated the wifi drivers to latest version (initially from the ASUS site which didnt fix it, then using the Intel Driver manager to the July 2016 release).
    My other computers use wireless AC with no issues, downloading at avg 120 Mbs.
    I even took an extern wifi adapter (TP-Link Archer T1U USB Wireless AC adapter) which was providing 120Mbs down on one laptop, plugged it in to my new ROG, and it was capped at 54Mbs.
    I can confirm in the router and Windows10 adapter settings i have indeed connected on Wireless AC @ 5Ghz with 680Mbs max bandwidth (love my Archer C7 Router)
    So it is connected to a pipe large enough to handle that kind of downstream traffic, but something is holding it back.

    I believe I've narrowed down that all my drivers are up to date, as well as Windows is finally fully patched after being out of the box.

    So, the only thing left is either some odd Windows 10 config (which i doubt, I've never run across a "Throttle to Wireless G" kind of option)
    Methinks Gamefirst IV is the culprit. Im not familiar with it, i know its bundled with ROGs, and is meant to throttle and prioritize packets for gaming.
    First step, i opened it and ticked the bottom right switch from ON to OFF (thinking, okay, this will fix it), but this had no affect.
    So i fully uninstalled Gamefirst IV anyway with CC Cleaner, just to be safe. Still no fix.

    Basically this new notebook is capped at wireless G speed.

    Any help would be much appreciated. I love this laptop so far, its awesome. I apologize if this is a duplicate,
    i've been searching around and didnt see anything that was resolved beyond updating drivers.
    This appears to be an OS or software configuration issue "out of the box"
    Last edited by soc.frangis; 09-09-2016 at 03:59 AM.

  2. #2
    New ROGer Array
    Join Date
    Sep 2016

    Problem Fixed (somewhat) -> So, the problem wasn't with the computer at all. its a problem with chrome (32 bit) & edge browser on Windows 10 +
    or using Google search engine speed test (google search "speed test")

    I went to, tried bing's speed test, and all give me a rate at 110-120 Mbs. (on both browsers)

    This is really bizarre, as I can run (netflix speed test) on my Android Tablet & Phones 64bit version of Chrome and it gives me speeds I would expect.
    I can also run it on my older ASUS laptop, using 32-bit Chrome in Windows 10, and it gives me a speed of 110-120 Mbs.

    So I guess there is a problem "somewhere" under the hood where this computer doesnt work well with Fast.Com (or google search speedtest).
    I literally have two ASUS laptops (different HW models) next to eachother, connected over wireless AC to the same router, and my
    older laptop gets 120Mbs just fine where as the newer one caps at 54mbs. (again only with and google search speed test).

    There must be something in their html5 or javascript that tries to detect my system config and it throttles down somehow.

    So i feel really really dumb not using speakeast, AT&T, or speedtest. I've defaulted to since it launched because its clean.

    It's good to know I'm getting the correct speed, but it doesnt change the fact that there is still something weird going on with the system configuraiton that
    causes some speed test webapps to throttle.

    Any thoughts?
    Last edited by soc.frangis; 09-18-2016 at 09:34 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts