Results 1 to 2 of 2
  1. #1
    ROG Guru: Yellow Belt Array a100 PC Specs
    a100 PC Specs
    MotherboardH97 Asus
    ProcessorIntel i7-4790 3.6GHZ
    Memory (part number)16GB
    Graphics Card #1Zotac GTX980Ti Reference OC`d GPU: +210MHZ - Memory: +300MHZ
    Sound CardOn board
    MonitorBenQ XL2430T Gaming LED Monitor
    Storage #1Samsung Evo Pro 850 512G SSD
    CPU CoolerRog Dual Fan
    CaseG20AJ
    Keyboard Asus
    Mouse Asus
    OS Win 8.1 Core Single Language
    Accessory #1 Logitech G27 Racing Wheel

    Join Date
    Aug 2015
    Reputation
    11
    Posts
    146

    G20AJ Slowed down - FPS drops in games - Help needed [solved]

    Hey guys, back again

    Last night something bad happened. My G20Aj started slowing down. whenever the PC goes under pressure in games fps drops and slows down.

    I checked hardwares and all passed:

    -CPU i7-4790 : Tested with Intel CPU Test app and all passed
    -GPU GTX980 Ti : tested with furmark with stress test Temps stayed at 70C max and fps was on 161 avg. (I`ve set a 600w green PC PSU directly for the gpu so it never has any power issues and been working brilliantly in the past few months)
    -RAM 2x 8g DIMM 1600 MHZ : tested with Windows Memory Diagnostic tool and no errors found
    - Hard Disk Samsung 850 EVO 500g SSD : Tested with HDD Health and all passed over 300 megabytes read and write speed. "Health OK" said the tool.

    But the moment I go into the games like Dragon Age Inquisition and Battlefield 4 it starts freezing and lagging.

    Interesting thing : when the game loads, it takes longer than before, when for instance Dragon Age loads into the game, terrain and texture of the game load slowly. Also whenever the autosaving icon shows it lags but once everything is loaded games goes smoothly. The moment I try to go some where else that its element arent loaded it lags again.
    Anyone has any ideas?

    Can this be System PSU?
    Last edited by a100; 09-10-2016 at 02:11 PM.

  2. #2
    ROG Guru: Yellow Belt Array a100 PC Specs
    a100 PC Specs
    MotherboardH97 Asus
    ProcessorIntel i7-4790 3.6GHZ
    Memory (part number)16GB
    Graphics Card #1Zotac GTX980Ti Reference OC`d GPU: +210MHZ - Memory: +300MHZ
    Sound CardOn board
    MonitorBenQ XL2430T Gaming LED Monitor
    Storage #1Samsung Evo Pro 850 512G SSD
    CPU CoolerRog Dual Fan
    CaseG20AJ
    Keyboard Asus
    Mouse Asus
    OS Win 8.1 Core Single Language
    Accessory #1 Logitech G27 Racing Wheel

    Join Date
    Aug 2015
    Reputation
    11
    Posts
    146

    Hih I got it fixed.

    For some reason my bios got reset the other night, so I forgot to load Optimized Bios Settings. Also windows Power Options settings were changed, dont know why and it was on power saving, I changed it to High Performance.

    Now all is good as before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •