Page 39 of 39 FirstFirst ... 29 37 38 39
Results 381 to 385 of 385

Thread: ROG Claymore

  1. #381
    ROG Member Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    5

    Can someone tell me what the heck is wrong with my Claymore?? It keeps disconnecting all time, and going all nuts. I´ve tested it on several computers, all Asus. But no, it might work for a day, or for a minute, then disconnects, and makes the whole system go nuts. I just bought a new Asus Rog Strix G513QR laptop, and no luck with the Claymore.

    FYI, I use the latest drivers, uninstalled and reinstalled Armoury, updated, downdated, done about everything you can do...and yet, that annoying usb-disconnect sound, and keyboard goes dark in the middle of a game...Really dissappointed in this thing.

  2. #382
    ROG Guru: Green Belt Array
    Join Date
    Feb 2019
    Reputation
    129
    Posts
    665

    I bought one when they first came out. Always had issues with it in one form or another. Then it locked on color cycle and stayed there. It went in the trash along with the spatha mouse and went all corsair.

  3. #383
    ROG Member Array
    Join Date
    May 2018
    Reputation
    10
    Posts
    5

    Quote Originally Posted by BigJohnny View Post
    I bought one when they first came out. Always had issues with it in one form or another. Then it locked on color cycle and stayed there. It went in the trash along with the spatha mouse and went all corsair.
    Yeah...I´m about to use this one for target practice with my shotgun. Worked for a couple of weeks, and I tought the problems was sorten, but F it, got worse. Yesterday it actually screwed up my new laptop pretty good. Lost bluetooth, resetted my bios, and made the whole laptop go nuts. I lost all other usb-ports when the Claymore was connected. Time for this one to go to keyboard-heaven.

  4. #384
    New ROGer Array
    Join Date
    May 2021
    Reputation
    10
    Posts
    1

    ROG Claymore detatchable Num Pad stopped working after driver update

    Hi guys... hopefully you guys will be able to help me. A few weeks (maybe couple of mnonths) ago I went to the Armoury app and ran all the pending updates on all the hardware I have from Asus. When going for the update on the Claymore (I believe it was the first time I've done an update on the keyboard since buying it back in May 2019) it said I should couple the Num Pad before running the update so that is what I did (I rarely have it connected, unless I need it for a specific task, otherwise I prefer the shorter keyboard) and then ran the update. After the update finished, the Num Pad has not worked since. I've tried in other pcs and nothing... no color, no keys working, nothing at all. Tried on both sides of the keyboard... still nothing.

    Has this happened to any other person? Anyone can help with this?

    Super thankful for any info and help you guys can give.

    Cheers, Goncalo

  5. #385
    ROG Guru: Brown Belt Array Brighttail PC Specs
    Brighttail PC Specs
    Laptop (Model)Asus G751JT
    MotherboardAsus x299 Rampage VI Extreme
    ProcessorIntel i9-7900x
    Memory (part number)Corsair Dominator Platinum SE 3200Mhz 4x8
    Graphics Card #1MSI GTX 1080TI
    MonitorAcer XB321HK (4k,IPS,G-sync)
    Storage #1Intel 900p (Boot) 2xSM961 (RAID 0) Games
    Storage #2Samsung 850 Pro 512GB - WD Black 4TB
    CPU CoolerCustom Water Cool
    CasePhanteks Enthoo Elite
    Power SupplyCorsair AX 1200i
    Keyboard Corsair Platinum 95
    Mouse Asus SPATHA
    Mouse Pad Corsair MM800
    Headset/Speakers Kanyo Y5
    OS Windows 10 64 bit
    Accessory #1 2 x Alphacool Full Copper Radiator 420mm/280mm
    Accessory #2 Monsoon MMRS reservoir w/ 2 x D5 Vario Pump
    Accessory #3 Monsoon Free Center Compression Fittings

    Join Date
    Sep 2014
    Reputation
    33
    Posts
    1,345

    I have the Claymore 2... is there a way to reset or roll back the firmware updates? My keyboard has been having issues since the last update with the ALT key seemingly stuck in the ON position even though the key isn't depressed. It makes typing impossible and before I look at RMAing, I thought I would try to roll back the firmware or reset it to the original.

    Is there a way to do this easily?

    Thanks
    Panteks Enthoo Elite / Asus x299 Rampage VI Extreme / Intel I9-7900X / Corsair Dominator RGB 3200MHz
    MSI GTX 1080 TI / 2x Intel 900p / Samsung 970 Pro 512GB
    Samsung 850 PRO 512GB / Western Digital Gold 8TB HD
    Corsair AX 1200i / Corsair Platinum K95 / Asus Chakram
    Acer XB321HK 4k, IPS, G-sync Monitor / Water Cooled / Asus G571JT Laptop

Page 39 of 39 FirstFirst ... 29 37 38 39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •