Page 35 of 38 FirstFirst ... 25 33 34 35 36 37 ... LastLast
Results 341 to 350 of 371

Thread: ROG Claymore

  1. #341
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by adamr View Post
    Just reading this now and I'm also stuck on 1.08. does not find new firmware [emoji20]
    Please check your inbox, the link for the latest firmware has been sent to you also.

  2. #342
    New ROGer Array
    Join Date
    Jul 2018
    Reputation
    10
    Posts
    1

    Unhappy How to reset or clear all the binds in asus rog claymore

    Hi, so accidently i've changed some binds in my keyboard so now basicly shift is useless and i cant write question marks and all of that, i want to know if there is a way to restore defaults on this device like it would be out of the box. Pls help

  3. #343
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by SorReN7123 View Post
    Hi, so accidently i've changed some binds in my keyboard so now basicly shift is useless and i cant write question marks and all of that, i want to know if there is a way to restore defaults on this device like it would be out of the box. Pls help
    Hold Fn+Esc for around 10 seconds. Functions are similar to those of the Flare.
    https://rog.asus.com/forum/showthrea...OG-Strix-Flare

  4. #344
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    13

    Just got my ROG Claymore today. Tried to install Armory but instantly getting error of "An installation support for could not be installed. Catastrophic Failure". I red about software problems when this keyboard was released but thought those would have been ironed out by now. Any tips to try?

  5. #345
    ROG Junior Member Array
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    3

    Here are the problems of my keyboard after updating the latest firmware 80% version 1.09.01

    1. number 8 key is working but LED is not illuminating anymore
    2. letter color rotation is not correct. more on RED now.
    3. F6, I, K, < and backspace is still showing dim color green even if set the LED light to off

    I want to downgrade or update again but I can't find any link to get the firmware

  6. #346
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by loccc View Post
    Just got my ROG Claymore today. Tried to install Armory but instantly getting error of "An installation support for could not be installed. Catastrophic Failure". I red about software problems when this keyboard was released but thought those would have been ironed out by now. Any tips to try?

    Try downloading Armoury again.
    You've probably tried reinstalling a few times, have you tried a different PC? Not many people encounter failed installs.

  7. #347
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by gsmhacks View Post
    Here are the problems of my keyboard after updating the latest firmware 80% version 1.09.01

    1. number 8 key is working but LED is not illuminating anymore
    2. letter color rotation is not correct. more on RED now.
    3. F6, I, K, < and backspace is still showing dim color green even if set the LED light to off

    I want to downgrade or update again but I can't find any link to get the firmware
    Please check your inbox, I have sent you the link to the Claymore firmware download.

  8. #348
    ROG Member Array
    Join Date
    Jun 2012
    Reputation
    10
    Posts
    5

    guys all my Fn commands doesnt work , do they work on x470 strix gaming F ?

  9. #349
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by Fate View Post
    guys all my Fn commands doesnt work , do they work on x470 strix gaming F ?
    Anyone else here having this issue?

    I have sent you the link to the latest firmware for your Claymore. Try flashing that, make sure your software and UEFI are up-to-date, then try again.
    Are you holding down the Fn key first before pressing anything else?

  10. #350
    ROG Junior Member Array
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    3

    Quote Originally Posted by MasterC@ASUS View Post
    Please check your inbox, I have sent you the link to the Claymore firmware download.
    updated the firmware to 80% 1.09.01 but the lighting issue on number 8 and letter E is still the same.

    my keyboard is rog claymore full version the one with removal numpad.. not the core version. not sure if there are difference on the firmware of the two version

Page 35 of 38 FirstFirst ... 25 33 34 35 36 37 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •