Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Sep 2016

    Card reader problem with G752VL

    I recently bought a G752VL and only today I needed to use the card reader, but it doesn't work.
    I tried with SD and SDHC cards that it my other laptop work without problems.
    I tried reinstalling the genesys driver, I saw something in here (for g751 I think) about uninstalling the genesys and using a realtek driver. That didn't work either.
    I tried disabling the card reader from bios but in Device Manager I can't see afterwards any disabled item. The drivers install without errors but still no card-reader device can be seen in Device Manager.
    Any ideas?

    Windows 10 x64 Home
    bios 2.19 (latest)

    Problem solved, I opened the case and although the connection between that small extension card and the motherboard looked ok, I took out the cable from sockets and I put it right back.
    Now it works just fine with the genesys driver.
    Probably it was an imperfect connection when they assembled the unit.
    Last edited by Miorlau; 09-30-2016 at 11:57 AM. Reason: solved

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts