Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    slow wireless with ROG G751JY ?

    I tried downloading some items, and noticed that the speed dropped real bad.

    with my G75VW I get 85 Mbit speed (not sure what was in here)
    and with this new laptop only 40-43 Mbit (Asus dual band Wireless AC 7260) seems like it

    Are there some setting to improve that?
    Tried even speeds tests, and all the same thing...


    Running into so many weird issues, that I am starting to dislike this laptop

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    nvm... see tons of other complaints about it...
    Tried different drivers, and they all suck...
    Send an e-mail to Asus, if I can't get a different wireless modem card.. like in my old G75VW machine.. that one works great... probably because it's not an intel..

  3. #3
    ROG Enthusiast Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    72

    Quote Originally Posted by pka4916 View Post
    I tried downloading some items, and noticed that the speed dropped real bad.

    with my G75VW I get 85 Mbit speed (not sure what was in here)
    and with this new laptop only 40-43 Mbit (Asus dual band Wireless AC 7260) seems like it

    Are there some setting to improve that?
    Tried even speeds tests, and all the same thing...


    Running into so many weird issues, that I am starting to dislike this laptop
    Thought i would give some input, if your running the anniversary edition its not your laptop. They currently have known broken issues including

    Broke wifi / wifi will disconnect loop

    Millions of users webcam are now broken because of the removal of H.285 and MJPEG. Currently only YUY camera work past 1minute

    Settings now now known issue and break when used.

    MS announced a update fix planned sometime after September.

    If you can roll back to 1511, its now advised an to manually try to stop the updates.

    If your running another OS version, then i would guess you found the right answers when you ran a search. Saw your Rog model as being fairly new, and just thought id post news i recently uncovered.

  4. #4
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    So... the previous version (1511) had high speeds ?

    Cause I am looking at the modems. and this one doesn't have the N part. only B/G while the G75VX has the B/G/N
    and the N is speeding it to 600-900 /
    correct me if i am wrong

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    I installed the old windows 10 version, and still the same problem with the speed.

    I saw some references with uninstalling Gamefirst, but that's not even installed yet.
    Tried different drivers and no luck either.
    someone mentioned driver version 17.13.11.5. that's the only one i didn't try.

    besides that are there other suggestions? and would .

    If i wanted to replace the wireless card.. where is it located? I can't seem to find any info on that

  6. #6
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013
    Reputation
    144
    Posts
    3,858

    I just posted in the other thread with speed tests that I just did.
    This was on G751JY that was an inplace upgrade from Win 8.1 to Win 10 and Win 10 anniversary edition completed about 2 week ago.
    There is plenty of info , search G751JY teardown. At least 100 youtube vids. its in the top right side, right about where the M2 key is.
    It most likely NOT the card.

  7. #7
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    Thank you.

    Think I am returning the laptop. I thought I fixed the Brown glow over all my screen, and it's on the laptop and not on other ones.
    After 4 days of being frustrated with the color, slow speed, disconnecting WiFi, randomly freezing, and super lagging when i play a video and do something in the background..
    I never had problems with my G75VW, but this one is nothing but problem..

  8. #8
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    ok got a new laptop, same model..
    This one the screen is good and no more freezing.
    They upgraded the Wireless to a Intel AC-8260 and still suffering with slow speeds.
    I want my 70-80 Mb speed back, and not the 20-30 Mb..
    I have the Windows Ani installed. but also tried the normal Window 10. and no difference.
    I played with the channels, and nothing.

    So I'm at a loss.
    When I look at the network properties it says i have a connecting of 144 Mb. but that ain't the case :/

    the previous ROG_G75VX had a Qualcomm Atheros Wireless card. and that one is a LOT faster than this one.

    first it had the default intel card in it, now the AC-8260 and still the same sucky speed

    I use an Asus Router RT-AC68U. My wifes cheap laptop, my Ipad Pro our Phones are superfast.. so it's something with this laptop / Wireless part.
    Last edited by pka4916; 09-22-2016 at 04:29 AM.

  9. #9
    ROG Guru: White Belt Array
    Join Date
    Nov 2015
    Reputation
    8
    Posts
    89

    Thumbs up Intel wifis slow

    Quote Originally Posted by pka4916 View Post
    They upgraded the Wireless to a Intel AC-8260 and still suffering with slow speeds.
    the previous ROG_G75VX had a Qualcomm Atheros Wireless card. and that one is a LOT faster than this one.
    Well the culprit is in fact Intel WiFi card. Intel has problems with those. On their forums there are threads of how ****ty intel wifis are. The thread about 7260 read it. Intel wifis are very unstable now the chip will overheat and throttle down speed or disconnect.
    Intel stated they have problem with Data Reordering. I can tell you this disconnects are not sporadic.
    I can say this issue also affects 8260 and Intel did not fix it in the latest v19.10 drivers, because with my G752vy I still get slowdowns or disconnects during large file transfers. I don't get problems with Azurewave AW-CB210NF which is Broadcom based. I recommend this card instead 8260 or 7260.
    Back in G73jh days Asus used to put Azurewave wifis in G laptops, why they switched to Intel?
    Last edited by winyl; 09-22-2016 at 12:49 PM.

  10. #10
    ROG Guru: Yellow Belt Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    149

    Thanks.

    Will the Killer™ Wireless-AC N1535 ac/a/g/n 2x2 NGFF + Bluetooth 4.1 work good?
    since I got it from HIDevolution (their service is awesome btw) and very happy with the much better laptop.

    Want to replace it myself, since i hate to ship it back and be without another 2 weeks.. have plenty of work deadlines to meet.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •