Results 1 to 7 of 7
  1. #1
    ROG Member Array nday76's Avatar
    Join Date
    Feb 2011
    Reputation
    13
    Posts
    22

    G73JH - I broke the main speaker while assembling

    I broke the speaker after repasting the thermal compound, while assembling back together, putting the speaker cord into fragile pins.

    At first attempt of re attaching the speaker cord, one of pin bent and got stuck inside of the cord.
    Pulled out gently and yet pulled out even more pins along. (i recall there were 5 pins total)

    As a result, all the pins were bent and fallen off, and now I hear the sound through the subwoofer with muffled sounds.

    I really like to fix the speaker if possible myself as there are no problems to this laptop.

    I know the possibility of soldering but, have anyone tried?

    or is there anyway to connect the speaker as it seems the cord is mainly for power...?

    please help me

  2. #2
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    From your description, it sounds like you mean you damaged the cable-end connector, not the speaker itself.

    If it has a connector that looks something like this, each individual wire just has a little clamped-on end that inserts into its own slot on in the connector. You can gently pull those wires out and straighten the ends.



    If you have another kind of connector, or if your are talking about the connector on the M/B itself, posting a photo would be helpful. That way we can get a good look and see what your options are.

  3. #3
    ROG Member Array nday76's Avatar
    Join Date
    Feb 2011
    Reputation
    13
    Posts
    22



    it is this part actually where there is five standing up pins that are super ultra fragile that you require to be extra careful with

  4. #4
    New ROGer Array
    Join Date
    Jun 2011
    Reputation
    10
    Posts
    1

    This is a kind of hackish way to do things but if you can figure out the pin out of the connector you can directly solder the wires to the mother board, or desolder the connector and look for a part number and try to find it on digikey.

  5. #5
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    Quote Originally Posted by nday76 View Post
    it is this part actually where there is five standing up pins that are super ultra fragile that you require to be extra careful with
    I can't really see the broken parts ihe photo, but from your added description, it seems you're saying that you broke some pins on the motherboard itself. So perhaps the speakers and it's cable/connector are not damaged at all?

    Anyway, if it's M/B pins, there's really no way to fix that without soldering. If you don't want to attempt it yourself, you'd have to bite the bullet and send it to Asus or a local repair shop to do it for you.

    You didn't specify which speaker if connected there, but until you get it fixed, you could probably improve the audio a little by adjusting the stereo mix and speaker balance....essentially moving all audio to the other speaker.

  6. #6
    ROG Member Array nday76's Avatar
    Join Date
    Feb 2011
    Reputation
    13
    Posts
    22

    Quote Originally Posted by BrodyBoy View Post
    I can't really see the broken parts ihe photo, but from your added description, it seems you're saying that you broke some pins on the motherboard itself. So perhaps the speakers and it's cable/connector are not damaged at all?

    Anyway, if it's M/B pins, there's really no way to fix that without soldering. If you don't want to attempt it yourself, you'd have to bite the bullet and send it to Asus or a local repair shop to do it for you.

    You didn't specify which speaker if connected there, but until you get it fixed, you could probably improve the audio a little by adjusting the stereo mix and speaker balance....essentially moving all audio to the other speaker.
    I haven't really took a picture of mine but, the image i post show the connector of the speakers which is placed in normally.
    the part I broke is the pins that connector should sit in.

    Soldering the whole thing might work but i'm not too sure.

    but thanks for the help guys

    please help me if there is anyone with experiences.

  7. #7
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    I mean no disrespect, @nday76, but from your responses, it sounds like you are way beyond your abilities to have someone direct you how to repair your system from online messages. I recommend you cut your losses and take your laptop to a qualified computer repair shop.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •