Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Mar 2014
    Reputation
    10
    Posts
    1

    H100i V2 problems with mounting bracket

    I have a corsair h100i V2 and a crosshair v formula-z 8350 cpu, I put everything together but I put the back plate on backwards, its probably shorting the board out so
    I'm getting an FF error code.

    I have a good reason why I mounted it on backwards, when I try and mount it the right way, its loose, like it literally wobbles, I know I'm missing something, the
    corsair instructions say you need to take off the black plastic hardware and just use the original mounting bracket but with out the black plastic brackets, the
    backplate literally wobbles.

    Any help would be appreciated.

  2. #2
    ROG Member Array ShadowDarkblade PC Specs
    ShadowDarkblade PC Specs
    MotherboardCROSSHAIR V FORMULA-Z
    ProcessorAMD FX 9590
    Memory (part number)CORSAIR Vengeance Pro 16GB 2400 (PC3 19200) Model: CMY16GX3M2A2400C11
    Graphics Card #1Vapor-X R9 290X 8GB GDDR5
    Storage #1Kingston SSDNow V300 Series 2.5" 240GB
    Storage #2Seagate Desktop HDD ST2000DM001 2TB 64MB Cache
    CPU CoolerCorsair H100i V2
    CaseCoolerMaster Haf 922
    Power SupplyRosewill Photon-1200w
    Keyboard cooler master octane Keyboard
    Mouse cooler master octane Mouse
    Headset/Speakers Pioneer VSX-D498 5.1 Recever
    OS Windows 10 Pro

    Join Date
    May 2016
    Reputation
    10
    Posts
    16

    I have the same cooler on my motherboard and on mine the back plate seems loose until I tighten the CPU block down onto the CPU I don't know why its so loose before you mount the block but once you mount the CPU block it should be tight that's how it worked for me.

  3. #3
    ROG Guru: Blue Belt Array sectionate PC Specs
    sectionate PC Specs
    MotherboardAsus Crosshair V Formula
    Processor8350 - 1090T
    Memory (part number)G Skill Sniper F3-14900CL9-4GBSR
    Graphics Card #1Asus GTX660-DC2O-2GD5
    MonitorAcer GD235HZ - ViewSonic VX2439wm - SyncMaster P2350
    CPU CoolerCorsair H100i
    CaseHAF 932
    Power SupplyCorsair Professional HX850
    Mouse Zowie EC1 eVo
    OS Microsoft Windows 7 Enterprise 64bit
    sectionate's Avatar
    Join Date
    Feb 2012
    Reputation
    57
    Posts
    878

    Are you using the right sized screws to connect the back plate (factory back plate) ? I have removed my h100i a few times and never had this issues you two are having. Maybe you can find some help here
    Last edited by sectionate; 11-18-2016 at 02:30 AM.
    Crosshair IV 1090T 4093.7 - Crosshair V FX - 8350 Batch # 1243PGT 4.422MHz - 4816.08 MHz 1.5v - GSKILL F3-14900CL9D-8GBSR(x2)1087.6 11-12-10 1.5volts - ViewSonic VX2439wm - Acer GD235HZ - SyncMaster P2350 - PowerColor Red Devil RX 480 8GBD5-3DH/OC - Current Mode: 5760 x 1080 - (retired) ASUS GTX660DC2O2GD5 - Nvidia 3D Vision Wired - HAF 932 - Corsair HX850 - Corsair H100i - latest quakelive.com - Day thirteen 60fps - as always I'm powered by Futurelooks.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •