Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Oct 2016
    Reputation
    10
    Posts
    2

    Exclamation Games disconnect while i play G750 JS on the ethernet cable - solved

    Hello!
    I keep having these issues with my Asus ROG G750 JS when i try to play online games like World of Warcraft,World of Warships ...etc on my ethernet connection.
    It happens like this:I start playing WoW for about 20-30 minutes and then i get randomly disconnected from the server.This issue happens only when i am connected to the internet via the ethernet cable,while i am on my WI-FI everything works ok but i can see that the ping is not as good as on my ethernet cable.
    I tried playing with my antivirus disabled(even unninstaled it ) to see if that was the problem but the same thing happened.
    Tried port forwarding it through my router(ZTE F660) but the problem persists.
    I also tried updating the drivers for the Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.30) but still nothing good happened.
    If it helps,my ISP is RDS&RCS Romania(1Gigabit connection).

    Any help will be very appreciated! (^__^)

  2. #2
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,108

    My first guess would be a bad connector or bad cable, either a broken wire some where in the cable, or a loose connection on either end cable or notebook or Router LAN socket.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  3. #3
    ROG Member Array anasmy PC Specs
    anasmy PC Specs
    Laptop (Model)Asus ROG G751JT
    MotherboardAsus Maximus VIII Hero
    ProcessorIntel Core i7 6700K
    Memory (part number)2x Corsair Vengeance LPX 8GB 3200MHz DDR4
    Graphics Card #1Asus Radeon RX480 Strix
    MonitorPhilips 223V (Temporary)
    Storage #1256GB Samsung 850 EVO
    Storage #2480GB Kingston HyperX Savage
    CPU CoolerBykski Custom Loop Watercooling
    CaseCorsair SPEC-ALPHA
    Power SupplyCorsair AX860
    Keyboard Logitech G910 Orion Spark
    Mouse Corsair Scimitar RGB
    Headset Corsair Void USB 7.1 Yellowjacket Edition
    Mouse Pad Razer Goliathus Extended
    Headset/Speakers Audio-Technica ATH-M30x
    OS Windows 10 Pro x64 + OS X El Capitan + Ubuntu 16.04

    Join Date
    Aug 2016
    Reputation
    10
    Posts
    11

    Games works normally on WiFi but not on LAN? That's odd.

    You can try:

    1. Check your connection from both ends (Make sure LAN cable is properly connected)
    2. Try a different port on the router
    3. Try a different LAN cable
    4. Do a ping test to your router when connected using Ethernet

    If non of those works, it might be your Laptop's LAN port
    Last edited by anasmy; 10-23-2016 at 05:34 PM.

  4. #4
    New ROGer Array
    Join Date
    Oct 2016
    Reputation
    10
    Posts
    2

    After some good hours of trobleshooting,port forwarding,rage and tears i managed to find a fix for this today.
    What i did:
    I looked through device manager to see if the drivers were up to date(they weren't) so i updated them -> nothing happened,same issue
    Tried a different source for drivers -> the problem persisted
    Reinstalled the drivers from the official ASUS website in the driver section for my laptop(the windows 8.1 version) and somehow this fixed it :|

    Funny thing is i spent a few hours looking through my router port forwarding section to see if everything was correct(ip,ports etc) and trying a different ethernet cable.
    The problem is now fixed...... sorry for the disturbance

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2016
    Reputation
    23
    Posts
    150

    Uninstall ROG gamefirst. That caused alot of problems for me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •