Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    ROG Enthusiast Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    38

    G752VS low performance?

    Hi, I have the G752VS (non-oc) and When I played GTA V on high settings I was only getting 50-60 fps, any ideas why my old G752VY used to play this game ast 60-70fps, any help would be greatly appreciated.

  2. #2
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse Microsoft PN7-00004 Bluetooth Mobile Mouse 3600
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 x64
    Accessory #1 XBox One S Bluetooth Gamepad
    Accessory #2 Competition Pro USB arcade joystick SpeedLink SL-6603-SPORTS-EU
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    24
    Posts
    569

    Drivers issues with 10x0 series. Take a look at NVidia Geforce drivers forum...

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    38

    Quote Originally Posted by hexaae View Post
    Drivers issues with 10x0 series. Take a look at NVidia Geforce drivers forum...
    So that means it'll be fixed soon ish?

  4. #4
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse Microsoft PN7-00004 Bluetooth Mobile Mouse 3600
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 x64
    Accessory #1 XBox One S Bluetooth Gamepad
    Accessory #2 Competition Pro USB arcade joystick SpeedLink SL-6603-SPORTS-EU
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    24
    Posts
    569

    Read here, recent topics about latest drivers releases: https://forums.geforce.com/default/board/33/

  5. #5
    ROG Enthusiast Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    38

    Quote Originally Posted by hexaae View Post
    Read here, recent topics about latest drivers releases: https://forums.geforce.com/default/board/33/

    I've updated my drivers to 375.86, by my perfromance is still low also I couldn't find any threads on there relating to my issue they seemed to all be about desktop 1070s, any idea where/when this could be fixed? thanks.

  6. #6
    ROG Guru: Yellow Belt Array
    Join Date
    Jun 2016
    Reputation
    23
    Posts
    150

    Go into the Nvidia control panel, 3D settings - Configure surround, physx, and select the GPU as the processor. That may help.

    There is also another graphics control panel which by default is set to POWER SAVING. I cant seem to remember which one, nor can i find it anymore, but i do remember it was the default setting when i got my new G752VY. Set it to PERFORMANCE, obviously. I hope you can sort this out, these laptops are a handful.

  7. #7
    ROG Enthusiast Array
    Join Date
    Sep 2016
    Reputation
    10
    Posts
    57

    What are your temperatures while playing?
    Is your power profile set to Performance? Are you using batery or power outlet?

  8. #8
    ROG Enthusiast Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    38

    Quote Originally Posted by Armesis View Post
    Go into the Nvidia control panel, 3D settings - Configure surround, physx, and select the GPU as the processor. That may help.

    There is also another graphics control panel which by default is set to POWER SAVING. I cant seem to remember which one, nor can i find it anymore, but i do remember it was the default setting when i got my new G752VY. Set it to PERFORMANCE, obviously. I hope you can sort this out, these laptops are a handful.
    I've checked my settings and I've changed a few now but still no luck unfortunately.

  9. #9
    ROG Enthusiast Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    38

    Quote Originally Posted by miguel pereira View Post
    What are your temperatures while playing?
    Is your power profile set to Performance? Are you using batery or power outlet?
    Hi, outlet all the way, and my temps are around 80-85C for the cpu (load) and 55-65C for the gpu

  10. #10
    ROG Enthusiast Array
    Join Date
    Sep 2016
    Reputation
    10
    Posts
    57

    Those GPU temps are on the low side, My guess is that the GPU is not with 100% load. Install afterburner and leave it logging the activity and game for some time and after it check what was lhe load in % for that game.

    One other note, could it be the g-sync active? Try to deactivate the g-sync and see what fps do you get. You have the 60hz screen or the 75hz screen?

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •