Results 1 to 6 of 6

Thread: Low FPS GL502VS

  1. #1
    ROG Member Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    11

    Low FPS GL502VS

    Hi All,

    Just got a new GL502VS today, and I'm noticing some very low FPS in games such as WoW, Civ 6, even in Heaven benchmark.

    Things seem to be locked at 30/40 FPS. Is this related to something with GSync? Should it be turned off? Or am I missing another setting that might unlock some higher frame rates on this computer.

    Thanks Everyone!

  2. #2
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,255

    Make sure your laptop is plugged into the wall when you're gaming or running GPU intensive benchmarks.

  3. #3
    ROG Member Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    11

    Quote Originally Posted by Chino View Post
    Make sure your laptop is plugged into the wall when you're gaming or running GPU intensive benchmarks.
    I do have it plugged in.

    Thank you.

  4. #4
    ROG Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    10

    Quote Originally Posted by terry00 View Post
    Hi All,

    Just got a new GL502VS today, and I'm noticing some very low FPS in games such as WoW, Civ 6, even in Heaven benchmark.

    Things seem to be locked at 30/40 FPS. Is this related to something with GSync? Should it be turned off? Or am I missing another setting that might unlock some higher frame rates on this computer.

    Thanks Everyone!
    Turn off G-Snyc.
    Also use "High performance" profile in windows power options.

  5. #5
    ROG Member Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    11

    Quote Originally Posted by Metallican View Post
    Turn off G-Snyc.
    Also use "High performance" profile in windows power options.
    Well, turning off GSync helped quite a bit, in Heaven and in WoW. Need to test Civ some more.

    Is keeping Gsync on though a smart move? Or does it not really matter.

    Thanks Everyone!

  6. #6
    New ROGer Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    5

    Same issue and I solved it

    I had to remove all of the NVIDIA driver/software off my machine using programs and features. Using the clean install function doesn't have the desired effect. Then I downloaded and installed the 375.95 driver from NVIDIA and used the express install option. It seems if you upgrade/clean install over the top of the factory installed driver or it persists some odd setting that makes it cap at 30FPS. Hope this works for you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •