Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 28
  1. #11
    ROG Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    8

    Finally bought the GL702VM-DB71 from Amazon, the laptop displays the Thunderbolt option in the bios so i guess it supports it, but do you know why can't I see the Thunderbolt port listed in the device admin?

    Edit: It seems like Asus released a Thunderbolt firmware update :http://dlcdnet.asus.com/pub/ASUS/nb/...826.1481677810
    Last edited by gerarg; 12-18-2016 at 01:02 AM.

  2. #12
    ROG Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    8

    Quote Originally Posted by gerarg View Post
    Finally bought the GL702VM-DB71 from Amazon, the laptop displays the Thunderbolt option in the bios so i guess it supports it, but do you know why can't I see the Thunderbolt port listed in the device admin?

    Edit: It seems like Asus released a Thunderbolt firmware update :http://dlcdnet.asus.com/pub/ASUS/nb/...826.1481677810
    Ok guys i figured this out, Thunderbolt shows as Intel USB 3.1 - 1.10 controller, i updated the firmware using the tool from the link above and now it shows that the NVM is 4.00, the PD is 1.07.06, it says that supports external GPUs and finally that the Thunderbolt version is indeed 3 for those who were wondering.
    The updater failed multiple times but in my case what fixed it was to keep Thunderbolt software configuration opened during the update.

  3. #13
    ROG Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    24

    Hey thanks for the tip!
    I actually tried the update on my GL502VM and it worked as well.
    For me it actually opened the Thunderbolt software on it's own as it was updating and I could see the controller poping up in it as well as in the Device Manager.
    Just like you said it was under USB 3.1 - 1.10. After the update it vanished but I am guessing that it will show up once there is something actually plugged into the port.
    My only question is where do you see the version number and that it's eGPU compatible?

  4. #14
    ROG Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    8

    Quote Originally Posted by andvoy View Post
    Hey thanks for the tip!
    I actually tried the update on my GL502VM and it worked as well.
    For me it actually opened the Thunderbolt software on it's own as it was updating and I could see the controller poping up in it as well as in the Device Manager.
    Just like you said it was under USB 3.1 - 1.10. After the update it vanished but I am guessing that it will show up once there is something actually plugged into the port.
    My only question is where do you see the version number and that it's eGPU compatible?
    I don't know how to post pictures so i will leave the link for a guide that helps you check which firmare version you have : https://downloadmirror.intel.com/261...date-Guide.pdf

  5. #15
    ROG Member Array
    Join Date
    Nov 2016
    Reputation
    10
    Posts
    24

    Thanks a lot! Found it!

    Can you confirm that this is what you are seeing in yours:
    [ATTACH=CONFIG]61204[/ATTACH

    The Service/Controller driver version as Unknown has me worried a little.
    Can you alos confirm that you are not seeing the Thunderbolt ports under Attached Device Chains unless there is something acutally plugged in?
    Miniatura de Adjuntos Miniatura de Adjuntos GL502VM_TB3.png  


  6. #16
    New ROGer Array
    Join Date
    Oct 2016
    Reputation
    10
    Posts
    2

    has anyone tried to connect to a razer core yet, or the akitio node https://www.akitio.com/expansion/node

  7. #17
    ROG Guru: Yellow Belt Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    128

    NVM version is way too low.

    Other brands with thunderbolt 3 have updated to nvm 15 or 16.

    NVM 4 would make it incompatible with a lot of devices.

  8. #18
    New ROGer Array
    Join Date
    Apr 2017
    Reputation
    10
    Posts
    3

    New GL702VM Owner

    I am a bit disappointed about what I am reading here.

    Anybody had any success with Thunderbolt on a GL720VM?

  9. #19
    ROG Guru: Yellow Belt Array StarJack's Avatar
    Join Date
    Apr 2017
    Reputation
    42
    Posts
    187

    Quote Originally Posted by Weltraum Affe View Post
    I am a bit disappointed about what I am reading here.

    Anybody had any success with Thunderbolt on a GL720VM?
    Just FYI, I have a new GL702VM Kaby Lake model and I was informed by ASUS that "In regards to the Thunderbolt 3, it gets 40Gbps (short or active cable); 20Gbps (long, passive cable)."

    I am yet to actually use the port myself but this response was encouraging.

  10. #20
    ROG Guru: Yellow Belt Array Bran187 PC Specs
    Bran187 PC Specs
    Laptop (Model)GL502VMK
    MotherboardMSI Z97 SLI Krait Edition
    Processori7 4790
    Memory (part number)16 GB GSkill DDR3
    Graphics Card #1EVGA GTX 1070
    MonitorHP Pavilion 32q
    Storage #1120 GB SSD
    Storage #21TB HDD
    CPU CoolerCM 212
    CaseFractal Define R4
    Power SupplySeasonic 650W
    Keyboard Corsair K55
    Mouse Corsair M65 Pro
    Headset Plantronics Rig
    Mouse Pad Glteck XXL
    OS Windows 10

    Join Date
    Oct 2012
    Reputation
    15
    Posts
    204

    Quote Originally Posted by StarJack View Post
    Just FYI, I have a new GL702VM Kaby Lake model and I was informed by ASUS that "In regards to the Thunderbolt 3, it gets 40Gbps (short or active cable); 20Gbps (long, passive cable)."

    I am yet to actually use the port myself but this response was encouraging.
    Hey StarJack, in the the Thunderbolt app under details does it say you have the 15BF in the thunderbolt controller generation section? Or does it say something else?

Page 2 of 3 FirstFirst 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •