Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Aug 2018
    Reputation
    10
    Posts
    3

    ROG GL703GE Fan Speed Goes Crazy

    Hi

    I have problem since first day i bought laptop...

    When i boot and log into Windows 10 my fans go crazy... they are constantly like in overboost mode and they are so loud...
    I uploaded BIOS i reset everything to default value, i installed hotkeys and tried to switch fan speed with FN+F5, same in gaming centre, and nothing can do the trick...

    Is there a way to fix this because it is annoying. if i were gaming or something that would cause laptop to warm up i would not say anything but this fan goes crazy after i start my OS.

    Please help.

  2. #2
    ROG Member Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    9

    Last edited by StepOne; 01-08-2019 at 10:10 PM.

  3. #3
    New ROGer Array KAB123456789 PC Specs
    KAB123456789 PC Specs
    Laptop (Model)GL703GE-ES73
    MotherboardSTRIX SCAR
    ProcessorIntel Core i7-8750H 2.20 GHz
    Memory (part number)32 GB 2666 MHz
    Graphics Card #1NVIDIA GeForce GTX 1050 Ti - 4 GB
    Monitor17.3" FHD 120 Hz
    Storage #1Samsung 970 PRO - M.2 NVMe
    CPU CoolerTHMODGL503
    OS Windows 10

    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Lightbulb How I Fixed Mine

    I have the GL703GE laptop, I'm providing a link to an image of what I dealt with, and then me working through my issue and finding a solution on another message board.

    The reason I'm doing this on this thread right here, instead of on the link provided, is that google searches direct you to this specific thread.

    https://i.imgur.com/geNLh2T.png

    https://forums.tomshardware.com/thre.../post-21412825

    Let me know if this helps anybody!

  4. #4
    Banned Array
    Join Date
    Oct 2019
    Reputation
    10
    Posts
    40

    solution was this, atleast for me.

    Click image for larger version. 

Name:	uFLIcFd.jpg 
Views:	0 
Size:	263.7 KB 
ID:	83058

  5. #5
    New ROGer Array KAB123456789 PC Specs
    KAB123456789 PC Specs
    Laptop (Model)GL703GE-ES73
    MotherboardSTRIX SCAR
    ProcessorIntel Core i7-8750H 2.20 GHz
    Memory (part number)32 GB 2666 MHz
    Graphics Card #1NVIDIA GeForce GTX 1050 Ti - 4 GB
    Monitor17.3" FHD 120 Hz
    Storage #1Samsung 970 PRO - M.2 NVMe
    CPU CoolerTHMODGL503
    OS Windows 10

    Join Date
    Nov 2019
    Reputation
    10
    Posts
    3

    Yeah, it's a bit washed out due to the bright light, we can't actually see it.

    Also, I think your notes on it are fine, it should be pretty obvious if you have an issue with the pin. If I continue having an issue, I'll probably check mine to make sure they're correct.

    On that note, I'll go ahead and mention my electrical tape isn't holding that well and I've had to go in multiple times to reset it. I was warned, I'm stubborn. One more time and I'll be checking this for sure.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •