Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 33 of 33
  1. #31
    New ROGer Array ranked001 PC Specs
    ranked001 PC Specs
    Laptop (Model)gl702vm
    Motherboardz170 gamer pro
    Graphics Card #1asus turbo gtx1060 6g
    Graphics Card #2gtx1060 6g
    CPU Coolerdeepcool maelstom 120
    Power Supplycorsair cx500
    Network Routeropenwrt

    Join Date
    Jan 2017

    ive tried every driver possible

    ive tried finding different drivers for i2c ive had microsoft input configuration device drivers and asus input configuration device drivers,
    the second i opened my laptop the right click didnt work, so going to microsoft generic hid device drivers gave me my right click back.
    ive scoured windows.update catalogue searched by device -vendor id, looked at other devices related to i2c
    asus seem to be using either a new i2c ACPI/elan1200 or theyve customized it so other drivers from elan wont work
    with fully updated drivers:
    scrolling breaks and the pointer breaks up and stutters and resets for a few minutes right click doesnt work on reboots, asus need to own upto this and bring an updated bios.

    with microsoft driver: still breaks up and tpuch input is un responsive

    this device had the same issue and was fixed with a bios update: Acer Aspire V5-591G

    it also has an elan i2c touchpad ACPI/elan1000

    they simply added an option in the bios to disable advanced touchpad features

    if this isn't sorted soon ill be sending my laptop back

  2. #32
    ROG Enthusiast Array
    Join Date
    Oct 2016

    Quote Originally Posted by E-squirrel View Post
    This issue and its resolution are mentioned in the FAQ section of the support page.

    If you don't want to read it, here are the steps:

    1. Open Device Manager
    2. Expand Human Interface Devices
    3. Right click on Microsoft Input Configuration Device and choose Update Driver
    4. Choose to search automatically..
    5. Let Windows install the new driver for this device

    I have a GL702VM and can confirm that it worked...and is still working after several reboots.
    This worked for me. Thanks

  3. #33
    ROG Member Array
    Join Date
    Mar 2017

    Exclamation A simple fix?

    I got this issue once, but on a GL502VMK.

    I only restarted the laptop and the problem was gone!

Page 4 of 4 FirstFirst ... 2 3 4

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts