Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    ROG Enthusiast Array Amenophis's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    71

    Keyboard wakes up ASUS Rogue out of its nap and I don't want that

    I have an ASUS Rogue Republic of Gamers with Windows 10 on board. For some strange reason (and weird also) I cannot stop the keyboard from waking the laptop out of sleep.
    I've gone into Device Manager, Keyboard, Properties, Power Management and unchecked "allow this Device to wake the computer." I've rebooted the machine but this still does not stop the keyboard from waking the computer out of sleep.
    I've gone into the BIOS but can see nothing there that gives me any option to overcome this unhappy problem. If you folks have got some advice or suggestions, I'm listening or is that looking.

  2. #2
    ROG Enthusiast Array Amenophis's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    71

    C'mon!!! You can't convince me no one on this forum doesn't have an answer or even an idea for this question! What happens on here if something difficult comes up???

  3. #3
    ROG Enthusiast Array
    Join Date
    Nov 2016
    Reputation
    11
    Posts
    59

    device manager , hid , power options , uncheck allow this device to wake up the computer

    you will have to find out the right one because asus installs a ton of devices there, just do trial and error

  4. #4
    ROG Enthusiast Array Amenophis's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    71

    Thanks for the reply. If you read my original post, you'll see I've already unchecked this. There are two listed under Keyboard and only one gives me the option of unchecking. I've done that several weeks back but this does not change anything, including after a reboot. If you've got something else to suggest, I'll appreciate your help.

  5. #5
    ROG Enthusiast Array
    Join Date
    Nov 2016
    Reputation
    11
    Posts
    59

    It works, but the device is in keyboards - HID Keyboard .. check the pic Click image for larger version. 

Name:	keyboard_device.png 
Views:	1 
Size:	128.7 KB 
ID:	61996

  6. #6
    ROG Enthusiast Array Amenophis's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    71

    Again thanks for the effort. When I go there and to Hardware ID's, the "allow this device to wake up the computer" is also unchecked. I've gone down through the list and each time, it is unchecked in each case. Remember, I've got a laptop. And under Device Manager, Keyboard, I have two listings there. The second one is called "Keyboard Device Filter" and does not give me the option of "Power Management." I'm thinking you've got something else in mind so I'll wait for your expertise.
    Last edited by Amenophis; 01-20-2017 at 09:56 AM.

  7. #7
    ROG Enthusiast Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    74

    try the following
    1. open a command prompt as admin
    2. type "powercfg -devicequery wake_armed": your keyboard should be listed there
    3. then type "powercfg -devicedisablewake "keyboardname"

  8. #8
    ROG Enthusiast Array Amenophis's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    71

    Here's the message I've gotten in the past and still do trying this command. It is as follows -
    "Unable to perform operation. An unexpected error (0x490) has occurred. Element not found."

    Remember, this is a lapboard keyboard.

  9. #9
    ROG Enthusiast Array Amenophis's Avatar
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    71

    I should have mentioned. When I type in "powercfg -devicequery wake_armed" I get this ...
    "Microsoft Sculpt Comfort Mouse (Mouse and Keyboard Center"
    There is nothing in this that gives me any options as to stopping the Keyboard from waking the laptop.

  10. #10
    ROG Enthusiast Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    74

    then try
    powercfg /devicequery wake_programmable
    if the keyboard is not listed, then it is not user-cobfigurable
    Last edited by cdma2k; 01-20-2017 at 11:43 PM.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •