Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    3

    Rog G751JT Battery not charging and doesn't go down (Stays at 35%)

    Just bought this laptop off craigslist, I new it had a battery issue when I first purchased it but I assumed that a battery replacement would fix that issue. Spent 2 hours lastnight replacing the battery, turned it on and the battery worked, but i'm now realizing that it isn't the batterys fault considering its not charging, its something else. The charger is fine, it's the original charger, and just tried to use a different charger and that didn't work either. When taken off charge laptop stays on, but the % doesn't go down (Stays at 35%)

    Anyone know a fix? Update of bios? Messed up motherboard?

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    107

    Quote Originally Posted by Jacawits View Post
    Just bought this laptop off craigslist, I new it had a battery issue when I first purchased it but I assumed that a battery replacement would fix that issue. Spent 2 hours lastnight replacing the battery, turned it on and the battery worked, but i'm now realizing that it isn't the batterys fault considering its not charging, its something else. The charger is fine, it's the original charger, and just tried to use a different charger and that didn't work either. When taken off charge laptop stays on, but the % doesn't go down (Stays at 35%)

    Anyone know a fix? Update of bios? Messed up motherboard?
    Where did you get the battery from? I know of some cheap chinese knock offs that don't work from the start
    Laptop: G751JL
    Processor: i7-4750HQ
    Graphics Card: GTX 965M
    Memory: 8 GB Samsung (stock)
    Storage #1: Samsung 850 EVO 250gb
    Storage #2: 1 TB 7200 rpm (stock)
    OS: Windows 10 x64

  3. #3
    ROG Member Array
    Join Date
    Jul 2012
    Reputation
    15
    Posts
    8

    Does windows say "Plugged in - Not Charging"? If so my 751 does this all the time. How I fix it is to shut down the laptop, unplug the power supply, then hold the power button down for about a minute. The plug it in and power it on. See if it's charging after that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •