Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    6

    TPM 2.0 for Strix X99

    Hello all,

    My configuration requires that I have BitLocker enabled on all drives. I run Windows 10 Pro (v10.0.14393). I have purchased a TPM module (TPM-M R2.0) through Amazon. I received the module, plugged it into my board, opened up the TPM administration console, cleared the TPM, restarted, pressed F12 to clear the TPM, got back into Windows and attempted to enable BitLocker on the OS drive.

    I cannot enable BitLocker on the OS drive. TPM administration reads a status of "The TPM is ready for use, with reduced functionality." The event log has an error that says "The device driver for the Trusted Platform Module (TPM) encountered a non-recoverable error in the TPM hardware, which prevents TPM services (such as data encryption) from being used. For further help, please contact the computer manufacturer." What driver is this alluding to? Where can I find this thing?

    I have read every scrap of the Windows TPM information and all of that stuff is great and all but not applicable at present as the OS can't read/write the TPM.

    Any help is much appreciated.

  2. #2
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    9

    Hello,

    I believe the Strix 99 motherboard is compliant with TMP module 1.2 standards and not 2.0. I think you have to buy a 1.2 model TPM module.

    /Goran

  3. #3
    ROG Member Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    6

    Quote Originally Posted by goran69 View Post
    Hello,

    I believe the Strix 99 motherboard is compliant with TMP module 1.2 standards and not 2.0. I think you have to buy a 1.2 model TPM module.

    /Goran
    Thank you, Goran. I ordered a 1.2 module from eBay. I will reply with the outcome.

  4. #4
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    9

    Thumbs up

    /G

  5. #5
    ROG Enthusiast Array
    Join Date
    Mar 2016
    Reputation
    12
    Posts
    67

    For whatever reason X99 platform is not compatible with TPM 2.0. Important to note BTW that the connector used for TPM 1.xx and 2.xx is different.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •