Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    3

    GL502VT touchpad stopped working

    Hi, my touchpad on my GL502VT stopped working after a computer crash. I tried the FN+F9 and it does not work. I also tried reinstalling the drivers from https://www.asus.com/uk/support/Down...SjhoZXNE7t/45/ and when it's installing I get this error: "There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor".

    Please help me, my next option is reinstalling Windows and I don't want to go through all that trouble since I have a lot of software installed for work.

    Best,

    Francisco Valencia

  2. #2
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    Uninstall the driver for your touchpad. If you can't see it in device manager, uninstall the PS/2 mouse. Then restart Laptop. Reinstall drivers, ATK package, Smart gesture, etc...

  3. #3
    New ROGer Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Julskey View Post
    Uninstall the driver for your touchpad. If you can't see it in device manager, uninstall the PS/2 mouse. Then restart Laptop. Reinstall drivers, ATK package, Smart gesture, etc...
    Thanks for the help, but I've tried that and it doesn't work, it says there's no communication with the device in the device manager. I think it's broken and a lot of people have had the same issue.

  4. #4
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    There is a good chance your internal pointing device got disabled. Go to BIOS and check Internal Pointing Device if it is enabled. Hit F9 for optimized defaults (this trick solved a G-sync problem in G752 before). Save and exit. I'm not 100% sure it will fix the problem but is worth a try.
    Last edited by Julskey; 02-17-2017 at 05:22 AM.

  5. #5
    New ROGer Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Julskey View Post
    There is a good chance your internal pointing device got disabled. Go to BIOS and check Internal Pointing Device if it is enabled. Hit F9 for optimized defaults (this trick solved a G-sync problem in G752 before). Save and exit. I'm not 100% sure it will fix the problem but is worth a try.
    I tried that, but it is enabled and keeps not working. Thanks for the help though!

  6. #6
    ROG Member Array
    Join Date
    Jan 2017
    Reputation
    10
    Posts
    23

    It's not a solution but it could help, what i do each time I turn on my lap is
    go to \Program Files (x86)\ASUS\ASUS PTP Driver\win10
    and double click on install all, then it works, I hope it works for you too

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •