Page 1 of 11 1 2 3 ... LastLast
Results 1 to 10 of 105
  1. #1
    ROG Enthusiast Array
    Join Date
    Mar 2016
    Reputation
    12
    Posts
    67

    ThunderboltEX 3 firmware update ?

    Guys,

    I have a ThunderboltEX 3 card running on my RVE. Since Intel latest drivers, posted in december and needed for W10 AU full compliance, I get at each W10 boot a popup to update my firmware that directs me here : https://thunderbolttechnology.net/updates.

    Thing is Asus hasn't posted a single FW update for the ThunderboltEX 3. It's running a very old firmware that doesn't support any modern TB devices. Level is NVM 8.xx with no support for external GFX or Network (to mention a few).

    Can anyone at Asus update us on the status of the TB3EX board ? Is it still supported ? Will there be a firmware update ? When ?

    Thanks.

  2. #2
    ROG Enthusiast Array hellokitty's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    72

    I own the same setup, i need a update also, they are so slow to update there Bios/Drivers.

  3. #3
    ROG Enthusiast Array hellokitty's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    72

    quit working

    Yeh now my card is dooing the same ****, wont work, it still shows in the bios, sometimes wont show in windows. i email asus, and i get the usual, make sure you have these drivers in stalled and these settings in your bios. I setup the card months ago and it was working, i re installed windows, did not fix it, i pulled cards and my m.2, did not fix it. My thunderbolt EX2 Dual still works, i had to put that back in. I think these cards fail quick, i need a rma.

  4. #4
    ROG Member Array bgen5pax PC Specs
    bgen5pax PC Specs
    MotherboardAsus Rampage V Extreme
    Processori7 5960X
    Memory (part number)32GB (4x8) Crucial Ballistix DDR4-2400
    Graphics Card #1Asus Matrix GTX980-P-4GD5
    MonitorAsus PB278Q
    Storage #1Asus RAIDR Express PCIe SSD 240G
    CPU CoolerNoctua NH-U12S
    CaseCoolermaster Silencio 652S
    Power SupplyCoolermaster G650M
    OS Windows 10 Pro x64
    Network RouterAsus DSL-N17U

    Join Date
    Sep 2016
    Reputation
    10
    Posts
    9

    Here is my experience with TBEX3

    My card also stops working after a while. Since I use my home PC every weekend and remains unpowered during weekdays, TBEX3 vanishes from BIOS completely. It's not detected in the NB Agent as a x4 adapter at all. All I have to do to remedy this is to take these steps:

    i. Reset to BIOS defaults with the button at the back,
    ii. Enter my settings manually or by loading from stored profile,
    iii. TURN OFF Thunderbolt (in Advanced Menu),
    iv. Save and boot in Windows (remember, no TB at this stage, it's off in the BIOS),
    v. Restart and once inside BIOS, turn ON Thunderbolt and careful to set the correct NB or SB and Pciex slot,
    vi. Save and boot in Windows, TB functional again,
    vii. Repeat procedure every weekend.

    Hope this helps

  5. #5
    ROG Enthusiast Array hellokitty's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    72

    Yep

    Quote Originally Posted by bgen5pax View Post
    My card also stops working after a while. Since I use my home PC every weekend and remains unpowered during weekdays, TBEX3 vanishes from BIOS completely. It's not detected in the NB Agent as a x4 adapter at all. All I have to do to remedy this is to take these steps:

    i. Reset to BIOS defaults with the button at the back,
    ii. Enter my settings manually or by loading from stored profile,
    iii. TURN OFF Thunderbolt (in Advanced Menu),
    iv. Save and boot in Windows (remember, no TB at this stage, it's off in the BIOS),
    v. Restart and once inside BIOS, turn ON Thunderbolt and careful to set the correct NB or SB and Pciex slot,
    vi. Save and boot in Windows, TB functional again,
    vii. Repeat procedure every weekend.

    Hope this helps
    That sounds like Standard Operating Procedeeder "Asus SOP" . I went back to my deluxe dual tb2. It works . waiting to here back to RMA

  6. #6
    ROG Enthusiast Array
    Join Date
    Mar 2016
    Reputation
    12
    Posts
    67

    Same problem here with the card suddenly disappearing from Windows Right now it shows as USB 3.1 controller. But the ThunderBolt part has vanished. God only knows why.

    Asus, can you please do something ? :-)

  7. #7
    ROG Member Array bgen5pax PC Specs
    bgen5pax PC Specs
    MotherboardAsus Rampage V Extreme
    Processori7 5960X
    Memory (part number)32GB (4x8) Crucial Ballistix DDR4-2400
    Graphics Card #1Asus Matrix GTX980-P-4GD5
    MonitorAsus PB278Q
    Storage #1Asus RAIDR Express PCIe SSD 240G
    CPU CoolerNoctua NH-U12S
    CaseCoolermaster Silencio 652S
    Power SupplyCoolermaster G650M
    OS Windows 10 Pro x64
    Network RouterAsus DSL-N17U

    Join Date
    Sep 2016
    Reputation
    10
    Posts
    9

    Quote Originally Posted by linxeye View Post
    Same problem here with the card suddenly disappearing from Windows Right now it shows as USB 3.1 controller. But the ThunderBolt part has vanished. God only knows why.

    Asus, can you please do something ? :-)
    This is exactly what happens to me too. If I use my PC on a daily basis, I have no problems whatsoever, TB3+USB3.1 are recognized in both BIOS and Win10.
    If the PC remains off for 2-3 days, TBEX3 vanishes from BIOS and only USB3.1 is working inside Windows.
    Every time I have to do the procedure I outlined above to get it working again.

  8. #8
    ROG Enthusiast Array
    Join Date
    Mar 2016
    Reputation
    12
    Posts
    67

    So what should we do to get this card working as it should ? Asus, please ?

  9. #9
    ROG Enthusiast Array hellokitty's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    72

    I did the support i think? 2 months ago, they said they had to move to a higher tier, still no word from them. My thunderbolt 2 still working, sometimes it fails on startup, but i usally get it back after another restart.

  10. #10
    ROG Enthusiast Array hellokitty's Avatar
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    72

    Rma

    well now they want me to rma it, after months and numerous pointless emails. They need to get there support together. well i just bought a Gigabyte Alpine ridge thunderbolt 3 card, very hard to find, coming from germany. from what i have read this should work, but i wonder if it will have same issues?

Page 1 of 11 1 2 3 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •