Results 1 to 7 of 7
  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    136

    Rampage IV Extreme Windows 10 AI Suite

    Is there a version that works on windows 10 for the RIVE? *I have a H97i-Plus board running win 10 on other system and fine with the USB boost running my USB 3.0 drive copies are MUCH faster.*

  2. #2
    ROG Enthusiast Array XIIIIX PC Specs
    XIIIIX PC Specs
    MotherboardR4 BE
    Processor4930
    Memory (part number)Gskill
    Graphics Card #1GTX1080
    Sound CardX7 LE
    MonitorBig enough
    CaseLevel 10
    Keyboard Claymore
    Mouse Spatha
    Headset AKG
    Mouse Pad Rog big one
    Headset/Speakers Harman GLA
    OS W10

    Join Date
    Feb 2017
    Reputation
    10
    Posts
    63

    For the BE it worked.
    Win10 - 64 straight from Asus website.
    (As for going from X79 to 87 it worked simply via a HD clone and a couple of reboots ;-)

  3. #3
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    136

    Quote Originally Posted by XIIIIX View Post
    For the BE it worked.
    Win10 - 64 straight from Asus website.
    (As for going from X79 to 87 it worked simply via a HD clone and a couple of reboots ;-)
    Not sure what your saying. Try to install what version on the RIVE x79?

  4. #4
    ROG Enthusiast Array XIIIIX PC Specs
    XIIIIX PC Specs
    MotherboardR4 BE
    Processor4930
    Memory (part number)Gskill
    Graphics Card #1GTX1080
    Sound CardX7 LE
    MonitorBig enough
    CaseLevel 10
    Keyboard Claymore
    Mouse Spatha
    Headset AKG
    Mouse Pad Rog big one
    Headset/Speakers Harman GLA
    OS W10

    Join Date
    Feb 2017
    Reputation
    10
    Posts
    63

    Quote Originally Posted by rmilyard View Post
    Not sure what your saying. Try to install what version on the RIVE x79?
    I use the R4 Black Edition, and the latest version works wit Windows10
    I use Window10 64.
    The R4BE is basically the same board as the R4Extreme

    I have made a clone from that image, and dropped it in my Maximus 6.
    It worked with no problems. It only had to reboot a few times.
    Probably the reboots are driver/chipset related

    I`ve taken the latest AI-suite version from the Asus website, the latest Intel drivers from the intel website, Nvidia etc.
    The latest AI - version, if I remember correctly was from the Z97 and/or X99 range.
    It installs, and works fine. After that driver updates etc. again.

    Sorry, but I can`t hotlink the download link.
    https://www.asus.com/Motherboards/MA...Desk_Download/

    Select Win10
    Select Util
    Scroll halfway down to AI-suite, and download.
    Have fun
    Last edited by XIIIIX; 02-25-2017 at 06:27 PM.

  5. #5
    ROG Guru: Yellow Belt Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    136

    Quote Originally Posted by XIIIIX View Post
    I use the R4 Black Edition, and the latest version works wit Windows10
    I use Window10 64.
    The R4BE is basically the same board as the R4Extreme

    I have made a clone from that image, and dropped it in my Maximus 6.
    It worked with no problems. It only had to reboot a few times.
    Probably the reboots are driver/chipset related

    I`ve taken the latest AI-suite version from the Asus website, the latest Intel drivers from the intel website, Nvidia etc.
    The latest AI - version, if I remember correctly was from the Z97 and/or X99 range.
    It installs, and works fine. After that driver updates etc. again.

    Sorry, but I can`t hotlink the download link.
    https://www.asus.com/Motherboards/MA...Desk_Download/

    Select Win10
    Select Util
    Scroll halfway down to AI-suite, and download.
    Have fun

    Getting The model does not support this application when trying to install.

  6. #6
    ROG Enthusiast Array XIIIIX PC Specs
    XIIIIX PC Specs
    MotherboardR4 BE
    Processor4930
    Memory (part number)Gskill
    Graphics Card #1GTX1080
    Sound CardX7 LE
    MonitorBig enough
    CaseLevel 10
    Keyboard Claymore
    Mouse Spatha
    Headset AKG
    Mouse Pad Rog big one
    Headset/Speakers Harman GLA
    OS W10

    Join Date
    Feb 2017
    Reputation
    10
    Posts
    63

    Quote Originally Posted by rmilyard View Post
    Getting The model does not support this application when trying to install.
    Click image for larger version. 

Name:	AI-suite.jpg 
Views:	7 
Size:	131.0 KB 
ID:	62721

    Did you install with Asussetup or setup? Setup is the one I use.
    The 1056 version is the one I used.
    After that I did all the latest updates.
    Or send me a pm with you`re mail-adres, and Ill make you an upload.

  7. #7
    ROG Enthusiast Array XIIIIX PC Specs
    XIIIIX PC Specs
    MotherboardR4 BE
    Processor4930
    Memory (part number)Gskill
    Graphics Card #1GTX1080
    Sound CardX7 LE
    MonitorBig enough
    CaseLevel 10
    Keyboard Claymore
    Mouse Spatha
    Headset AKG
    Mouse Pad Rog big one
    Headset/Speakers Harman GLA
    OS W10

    Join Date
    Feb 2017
    Reputation
    10
    Posts
    63

    Send you a wetransfer link.

    Install the W7-8-... version
    Then install the W10 drivers found on the Asus support site, and all should work well.

    Strange you had problems with the version. The X99 R5E works for me also ....

    Good luck, and keep us posted.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •