Results 1 to 8 of 8
  1. #1
    ROG Member Array
    Join Date
    Apr 2016
    Reputation
    10
    Posts
    5

    Angry PC wont start after installing new graphics card

    my pc works correctly when i used it with gtx 680 but i have gotten new g1 gtx 970 graphics card and when i insert the card and powers it my pc lights just flash but wont start.
    when i remove the pcie cables, the pc starts and i get info on monitor to power down and plug in the pcie cables. please help me cos i dont know what to do.
    my system specs are

    i7 3770k
    asus maximus v formula
    cooler master m850 (rs 850 esba)
    5tb hardisk
    8gn ram
    gigabyte gtx 970

  2. #2
    ROG Guru: Orange Belt Array brkkab123 PC Specs
    brkkab123 PC Specs
    MotherboardAsus Maximus VIII Hero
    ProcessorIntel Core i5 6600K
    Memory (part number)G.Skill Ripjaws V DDR4 3200 32GBs
    Graphics Card #1Sapphire NITRO+ RX 480 OC 8GB
    Sound CardOnboard sound
    MonitorLG 25UM58-P
    Storage #1Samsung 850 EVO 1.0TB m.2
    Storage #2Samsung 850 EVO 1.0TB SATA & W.D. Black 2.0TB
    CPU CoolerEK Water Blocks EK-XLC Predator 240 1.1 w/push/pull add-on fans kit
    CaseNZXT Phantom 820
    Power SupplyEVGA SuperNOVA 1000 G2
    Keyboard Logitech G213 Prodigy
    Mouse Logitech G403 Prodigy
    Headset/Speakers Logitech X530 5.1
    OS Windows 10 Pro x64
    Network RouterNetgear WNDR 3700
    Accessory #1 Logitech c615 HD Webcam
    Accessory #2 Seagate Backup Desk 3.0TB
    Accessory #3 Logitech U920 Driving Force Racing Wheel/Logitech Driving Force Shifter/GT Omega Wheel Stand

    Join Date
    Feb 2013
    Reputation
    10
    Posts
    307

    Did you uninstall the old drivers from the GTX680 before installing the gtx 970? Important and must be done as it's a 2 series jump in video cards.
    After doing that reinstall the 970 & go into your uefi/bios, load optimized defaults, so it detects the new 970 video card, rechange any other settings you changed previously and press F10 to save and exit. Then redownload the newest video card drivers from Nvidia for your GTX 970 and your o.s. version(Windows 7, Windows 10,Linux, etc.)
    Last edited by brkkab123; 03-06-2017 at 06:49 AM.

  3. #3
    ASUS HQ Service Rep Array
    Join Date
    May 2016
    Reputation
    12
    Posts
    417

    hi Aledjo

    hope You can solve

    Steps to work around that do something:
    Reset the BIOS via unplug/ clr jumpers
    Make BIOS Upgrade to the new version
    Remove the graphic cards and reinstall including change different slots
    as brkkab123 has mentioned uninstall the old drivers from the GTX680 before installing the gtx 970

  4. #4
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2016
    Reputation
    8
    Posts
    208

    Quote Originally Posted by FuryA@ASUS View Post
    hi Aledjo

    hope You can solve

    Steps to work around that do something:
    Reset the BIOS via unplug/ clr jumpers
    Make BIOS Upgrade to the new version
    Remove the graphic cards and reinstall including change different slots
    as brkkab123 has mentioned uninstall the old drivers from the GTX680 before installing the gtx 970
    Why do you think it has something to do with drivers, when the computer doesn't even start? Please explain how you come to a conclusion like that.

  5. #5
    Administrator Array Silent Scone@ASUS's Avatar
    Join Date
    Mar 2016
    Reputation
    124
    Posts
    1,801

    1) What Q-CODE is displayed on the motherboard when the system is powered up with both PCIE cables connected?

    2) Try using an alternate output (HDMI/DP)

    3) Update to the latest UEFI using USB Flashback

    Report back if no change.

  6. #6
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2016
    Reputation
    8
    Posts
    208

    Quote Originally Posted by Aledjo View Post
    my pc works correctly when i used it with gtx 680 but i have gotten new g1 gtx 970 graphics card and when i insert the card and powers it my pc lights just flash but wont start.
    when i remove the pcie cables, the pc starts and i get info on monitor to power down and plug in the pcie cables. please help me cos i dont know what to do.
    my system specs are

    i7 3770k
    asus maximus v formula
    cooler master m850 (rs 850 esba)
    5tb hardisk
    8gn ram
    gigabyte gtx 970
    It is you powersupply. Try another powersupply and/or pcie cable. If your computer starts when pcie cable is disconnected and inform you to connect pcie cable....it really points to problem with power to your graphic card. Remember you have to connect 2 6pin pcie cables, and check if they are connected properly (you should hear a click)

  7. #7
    ROG Enthusiast Array Shenny PC Specs
    Shenny PC Specs
    MotherboardAsus Maximus VIII Ranger
    Processori5-6600K @ 4.4 GHZ (Skylake)
    Memory (part number)2 x 8 GB Kingston DDR4 2666 MHz
    Graphics Card #1Gigabyte GTX 1080 G1 Gaming
    MonitorAsus ROG Swift PG279Q
    Storage #1Intel SSD 330 240 GB
    Storage #2Seagate External HDD 4 TB
    Power SupplyCorsair RM 850x
    Keyboard Logitech G15
    Mouse Logitech G9
    OS Windows 10 x64

    Join Date
    Sep 2016
    Reputation
    10
    Posts
    32

    Are you absolutely sure that the graphics card is in a working condition? If not, you should try it on another configuration.
    Problems with the PSU is also a possibility.

    Last year I upgraded from GTX 780 to GTX 1080 - absolutely no problem and the card overclocks well.

  8. #8
    ASUS HQ Service Rep Array
    Join Date
    May 2016
    Reputation
    12
    Posts
    417

    Quote Originally Posted by emsir View Post
    Why do you think it has something to do with drivers, when the computer doesn't even start? Please explain how you come to a conclusion like that.
    Sorry emsir, just explain
    The final step , if all steps have done and when it works at OS environment

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •