Results 1 to 7 of 7
  1. #1
    ROG Enthusiast Array mahanddeem PC Specs
    mahanddeem PC Specs
    MotherboardAsus Maximus IX Hero Z270
    Processor7700K
    Memory (part number)Corsair DDR4 3200MHz XMP
    Graphics Card #1Gigabyte GTX1080 Xtreme Gaming
    MonitorBenQ 1080p 144Hz
    Storage #1Samsung 960 EVO nvme 250GB
    Storage #2Samsung SSD 840 Pro 256GB
    CPU CoolerNoctua D15S
    CaseNZXT Phantom 410
    Power SupplyCorsair AX750
    OS Windows 10 Pro
    mahanddeem's Avatar
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    34

    Possible bug in current Maximus IX Hero? or I am missing something?

    Hello,
    I just upgraded from Maximus VII Hero to IX Hero(0801 BIOS) with 7700K.

    In my older Hero mainboard, My PC used to boot from my SSD (no.1 in boot order and in boot override, no.2 is my HDD). Even when I have a USB thumb drive connected to PC when I boot, It always boots from my SSD(unless I format SSD and it will say no boot device error).
    Now with the IX, I can't seem to find the option to make PC ALWAYS boot from my SSD C driver, it always checks and boots first from USB flash driver(if it is bootable), THEN it boots from SSD if no USB drive is connected.

    This is annoying when installing windows from flash disk, because when the first part of Windows install finishes and PC reboots, it should start booting from SSD and not AGAIN from USB drive.

    Is this a bug or some BIOS option am I missing?

    Thanks

  2. #2
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,255

    You can find the options to modify the boot list in the Boot tab in the BIOS.

    As for installing Windows, just disconnect the USB pendrive when it restarts.

  3. #3
    ROG Member Array wmakaiwi PC Specs
    wmakaiwi PC Specs
    Laptop (Model)Home built PC - Dime Bolt
    MotherboardAsus ROG Maximus VIII Hero
    Processori7 6700k 4.6 GHz
    Memory (part number)Corsair Vengeance LPX 3200
    Graphics Card #1EVGA GTX 970 FTW 2.0+
    Graphics Card #2EVGA GTX 970 FTW 2.0+
    Sound CardOnboard - SupremeFX
    Storage #1480 GB SSD
    Storage #2960 GB SSD
    CPU CoolerCorsair H100i v2
    CaseCorsair Carbide 300R Windowed
    Power SupplyEVGA SuperNova 1300W G2
    Keyboard Razer DeathStalker
    Mouse steelseries RAW sensei
    OS Windows 10 Pro X64
    Network RouterAsus RT-AC3100

    Join Date
    Jun 2014
    Reputation
    10
    Posts
    9

    I had the same issue today. I had to pull the thumb drive out before the 1st reboot. Then all went along normally. Have you checked the CSM settings? I set "boot for storage devices" to UEFI first and "Secure boot" to Other OS, since I installed Windows 7.

  4. #4
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,255

    This shouldn't be an issue for most users. How many of us actually reformat our computers every week? lol

  5. #5
    ROG Guru: Gold Belt Array Menthol PC Specs
    Menthol PC Specs
    MotherboardM 10 Apex / XI gene
    Processor8700K / 9900K
    Memory (part number)2x8 Gskill Trident Z 4266/2x2x8 Gskill Trident Z 4500
    Graphics Card #1RTX 2080ti / GTX 1060
    Sound CardSoundBlaster Ae5 / Onboard
    MonitorBENQ 32" 4K
    Storage #1Intel 900p 480GB/Samsung 960 Pro 1TB
    Storage #2Intel 750 1.2TB/Plextor 1 TB 2X 950 Pro
    CPU CoolerCorsair H150i AIO / H1110i
    CaseCorsair 740 ? Lian Li Air
    Power SupplyCorsair AX 1200i / AX 1200i
    Keyboard Corsair
    Mouse ASUS Strix
    Headset HyperX Cloud Alpha
    Mouse Pad ASUS
    Headset/Speakers Logitech Z906
    OS 10 X64 Pro
    Network RouterVerizon Fios
    Accessory #1 Intel Wifi BT pcie card
    Accessory #2 Red Bull
    Accessory #3 English Breakfast Tea
    Menthol's Avatar
    Join Date
    Jan 2012
    Reputation
    241
    Posts
    4,547

    Quote Originally Posted by Chino View Post
    This shouldn't be an issue for most users. How many of us actually reformat our computers every week? lol
    Not on my weekly todo list.

    When you install an OS set boot device to the drive you will be installing your OS on and use F8 during boot to select the OS media, on reboot it should boot to the OS drive

  6. #6
    ROG Enthusiast Array mahanddeem PC Specs
    mahanddeem PC Specs
    MotherboardAsus Maximus IX Hero Z270
    Processor7700K
    Memory (part number)Corsair DDR4 3200MHz XMP
    Graphics Card #1Gigabyte GTX1080 Xtreme Gaming
    MonitorBenQ 1080p 144Hz
    Storage #1Samsung 960 EVO nvme 250GB
    Storage #2Samsung SSD 840 Pro 256GB
    CPU CoolerNoctua D15S
    CaseNZXT Phantom 410
    Power SupplyCorsair AX750
    OS Windows 10 Pro
    mahanddeem's Avatar
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    34

    Quote Originally Posted by Menthol View Post
    Not on my weekly todo list.

    When you install an OS set boot device to the drive you will be installing your OS on and use F8 during boot to select the OS media, on reboot it should boot to the OS drive
    That's what I'm exactly doing. If you read my OP.
    Still, I have to run to disconnect Windows USB stick before first reboot for Windows install.

  7. #7
    ROG Guru: Gold Belt Array Menthol PC Specs
    Menthol PC Specs
    MotherboardM 10 Apex / XI gene
    Processor8700K / 9900K
    Memory (part number)2x8 Gskill Trident Z 4266/2x2x8 Gskill Trident Z 4500
    Graphics Card #1RTX 2080ti / GTX 1060
    Sound CardSoundBlaster Ae5 / Onboard
    MonitorBENQ 32" 4K
    Storage #1Intel 900p 480GB/Samsung 960 Pro 1TB
    Storage #2Intel 750 1.2TB/Plextor 1 TB 2X 950 Pro
    CPU CoolerCorsair H150i AIO / H1110i
    CaseCorsair 740 ? Lian Li Air
    Power SupplyCorsair AX 1200i / AX 1200i
    Keyboard Corsair
    Mouse ASUS Strix
    Headset HyperX Cloud Alpha
    Mouse Pad ASUS
    Headset/Speakers Logitech Z906
    OS 10 X64 Pro
    Network RouterVerizon Fios
    Accessory #1 Intel Wifi BT pcie card
    Accessory #2 Red Bull
    Accessory #3 English Breakfast Tea
    Menthol's Avatar
    Join Date
    Jan 2012
    Reputation
    241
    Posts
    4,547

    I guess I am stubborn or hard headed but I use a USB DVD drive to install my OS, no issues so I do see a reason to change what works
    I typically use the provided disk drive to install drivers (if it's a new system), just check the drivers I want to install and let it do it's thing, always works
    I have installed from USB thumb drive but I seem to format them to transfer files so as Long as I have an OS ISO image burnt to a disk I use that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •