Results 1 to 1 of 1
  1. #1
    ROG Guru: Orange Belt Array Dicehunter PC Specs
    Dicehunter PC Specs
    MotherboardAsus ROG Crosshair Hero VIII X570
    ProcessorAMD Ryzen 5800X PBO
    Memory (part number)Corsair Vengeance Pro RGB - 32GB - 3600MHz *4x8GB*
    Graphics Card #1MSI RTX 2080 Ti Lightning Z 11GB @ 2000/7500
    Graphics Card #3Corsair Commander Pro
    Graphics Card #4Corsair RGB Fan LED Hub x 2
    MonitorLG 34GN850-B Nano IPS Ultrawide 3440x1440 160Hz
    Storage #1WD Black SN750 1TB + WD Heatsink
    Storage #2Western Digital Caviar Black 6TB + 6TB
    CPU CoolerCorsair H115i + 2 x Corsair HDRGB 140mm Fans
    CaseCorsair 680 X - Black + 6 x Corsair HDRGB 120/140mm Fans
    Power SupplyCorsair RMi 1000w + Black Cablemod Kit
    Keyboard Razer Huntsman Mini
    Mouse Razer Deathadder V2
    Headset Beyerdynamic DT770 Pro 250Ohm + Fiio K5 Pro
    Mouse Pad Razer Gigantus V2 XXL
    OS Windows 10 - Professional 64 Bit Edition
    Accessory #3 Asus ROG Spotlight
    Dicehunter's Avatar
    Join Date
    Aug 2011
    Reputation
    20
    Posts
    385

    X570 and Apple Products Issue

    So I got myself an iPhone, Set it all up and then went to put some music I have onto it through iTunes, But it didn't show up, Tried a different lightning cable, Nothing, The phone registers as being connected in Windows itself but doesn't show up in iTunes.


    Then I tried on my girlfriends Intel based laptop, Works instantly, I then tried on my HTPC which is also equipped with an Intel CPU, A Core i7 8600K, Showed up instantly in iTunes, My main rig is a 5800X on an X570 mobo with freshly installed and updated Windows 10 but to make sure I formatted my drive, Reinstalled Windows 10 and iTunes multiple times and still nothing.


    All USB ports work just fine with everything I have, Just not any Apple device, The odd thing is that Windows itself sees it but not iTunes, The iPhone is seen by iTunes instantly on my Intel system and my girlfriends Intel system, I also asked a friend of mine who is also on X570 and he mirrored my experience, I genuinely think this is still a USB issue on X570 boards, The Crosshair Hero VIII is updated with the latest bios.





Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •