Results 1 to 10 of 27

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    6

    Samsung 960 EVO and PRO M.2 not recognized in bios

    Hi all,

    Is there anyone who can help me with the following?

    I've recently bought the Crosshair VI Hero motherboard and a Ryzen r7 1800x. The system is functioning fine except for the M.2 SSD slot. I've tried two different Samsung drives, a 960 EVO (500 GB) and a 960 PRO (512 GB). Both are not recognized in BIOS and Windows 10 setup is also not recognizing the SSD's. I've already tried several BIOS settings (running version 1001) but nothing seems to work. I know for a fact that the SSD drives are OK. The retailer I bought them at tested them on a different motherboard and both were working fine.

    Has someone experienced the same issue and found a way to resolve this?

    Thanks in advance!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •