Page 3 of 3 FirstFirst 1 2 3
Results 21 to 24 of 24

Thread: Trident RGB

  1. #21
    ROG Member Array FredFlint PC Specs
    FredFlint PC Specs
    MotherboardC6H
    Processor1800X
    Memory (part number)G.Skill Trident Z RGB 32GB (4 x 8GB) 3200MHz C14D
    Graphics Card #1FuryX
    Storage #1Samsung SM951 256GB
    CPU CoolerH100i V2
    CasePhanteks Enthoo Evolv ATX - Silver
    Power SupplyEVGA 650W G2
    Keyboard Razer BlackWidow TE Chroma
    Mouse SteelSeries Rival 700

    Join Date
    Mar 2017
    Reputation
    10
    Posts
    21

    Quote Originally Posted by AtrixfizIeo View Post
    I would use the version 1.04.29 from another ROG board. Seems to work a lot better. I haven't had a chance to play with it, and try to break it. I am still dealing with a rouge colored ram stick myself haha
    Have just installed a version from a ROG z270 version 1.04.29 and it is working, hopefully it will continue next time I boot.

  2. #22
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    6

    Quote Originally Posted by Bahz View Post
    So you're confirming that with the replacement, the memory is now being detected properly inside the latest AURA software? It seems like quite a few people are having the same issues, it would be great if you can help confirm with more information. Thanks.
    Actually i got a set of corsair ram instead. I have used trident in a few builds, and liked it, but with the corsair led ram no issues now.

  3. #23
    Ex-employee Array
    Join Date
    Jun 2020
    Reputation
    108
    Posts
    2,154

    Quote Originally Posted by Sharky7337 View Post
    Actually i got a set of corsair ram instead. I have used trident in a few builds, and liked it, but with the corsair led ram no issues now.
    Great, thanks for the update.

  4. #24
    ROG Enthusiast Array AtrixfizIeo PC Specs
    AtrixfizIeo PC Specs
    MotherboardCrosshair VI hero
    Processor1700X
    Memory (part number)F4-3200C14D-16GTZR
    Graphics Card #1Asus STRIX 1080
    Monitor1 34'' LG ultrawide, 1 55'' Samsung 4K
    Storage #1Toshiba 128GB SSD, samsung evo 840 512GB SSD
    Storage #2(2) WD 2TB HDD, 1 WD 4TB, XPG M.2 1TB
    CPU CoolerH110I
    CaseLian Li Lancool One Digital
    Power SupplyEVGA 850
    Keyboard G910 Orion Spectrum
    Mouse Corsair Dark Orb
    Headset Corsair Void Pro RGB
    OS Windows 10 pro Advanced

    Join Date
    Mar 2017
    Reputation
    15
    Posts
    29

    Well figured I would just post up what has been going on with me, and my Trident RGB. Last week I had said that I had one ram stick go rouge color wise... well since then it as got worse, and I feel I might be RMA'ing my ram here pretty soon. On Saturday I started up the computer, and was greeted with a 0d no boot. I had one stick going rainbow(same one as before), and one with no RGB. So after some trouble shooting, I found the rainbow color one is causing the 0d, and the stick with no RGB is fine.... But will not light up. I'm hoping this is just another C6H issue. I had flashed 1002, the day before, just to give it a shot. I have since flashed back to 902 thinking that might have been the issue with the ram.. sadly it wasn't.
    I've cleared CMOS, re-flashed a different BIOS version, and swapped sticks around.. all with no effect on the one believed to be bad.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •