Results 1 to 8 of 8
  1. #1
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    8

    G20CB new SSD install, doesn't show up in bios but able to connect in Device Manager?

    Hello,

    I recently purchased a 500GB Samsung 850 EVO SSD. I was able to get in installed into the SSD bay into the computer and plugged in the power cable and connected the SATA to the motherboard. When I go into system BIOS the SSD does not show up but in Device Manager I am able to connect to it. I used the Samsung data Migration tool and transferred the existing HDD data to the new SSS.

    Has anyone installed a SSD and know how they got the BIOS to recognize the SSD?

    Thanks in advance.

  2. #2
    ROG Guru: Orange Belt Array chilinmichael's Avatar
    Join Date
    Dec 2012
    Reputation
    16
    Posts
    372

    When you say "SSD bay", can you be more specific? The one near the DVD drive or the one near the bottom? I also once seemingly had an issue seeing it in Bios I believe, but a Bios update fixed that. May be the revision you are on, but always be careful flashing your Bios and honestly it's not the end of the world if in the end, it's working.
    Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.

  3. #3
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    8

    Update

    Hello.
    Yes the SSD is connected in the SSD bay above the DVD Tray.

    Update: I can now see the SSD in boot manager but am still having a little trouble. If I disconnect the HDD from the motherboard or if I disable the drive in system bios the SSD will boot up normally. Then When I reconnect/enable the drive and go to boot manager I set boot option #1 to be the SSD. For boot option #2 I have tried setting it to the HDD or disabled. When I boot the system back up it still always boots from the HDD drive.

    I should note that currently the SATA configuration is set to RAID. Whenever I try AHCI on boot it gives the BSOD.

    Thanks in advance for any feedback .

  4. #4
    ROG Guru: Orange Belt Array chilinmichael's Avatar
    Join Date
    Dec 2012
    Reputation
    16
    Posts
    372

    That's to be expected. If you installed Windows in RAID mode, you have to make a registry edit to enable AHCI.

    If you're using Win 7: https://www.sevenforums.com/tutorial...s-7-vista.html

    Windows 10 (which isn't an edit, just follow instructions): http://triplescomputers.com/blog/unc...hci-operation/
    Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.

  5. #5
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    8

    AHCI enabled

    Thanks for the feedback chilinmichael. I was able to follow the steps for windows 10 and the system is able to boot with AHCI enabled.(no more BSOD) But the system is still booting from the HDD drive and not the SSD. I have made sure that the boot option #1 is still the SSD.

    Anyone have any suggestions otherwise I may try running DBAN on the HDD drive so it cant boot windows from it.

  6. #6
    ROG Guru: Orange Belt Array chilinmichael's Avatar
    Join Date
    Dec 2012
    Reputation
    16
    Posts
    372

    So are you saying you've cloned the HDD to the SSD and still have both in the PC? I can't remember off the top of my head, but is there a way to disable the HDD in Bios to test? I'd certainly want to do that before making any modifications to the HDD incase the clone wasn't truly successful.
    Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.

  7. #7
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    8

    SSD working

    Yes I cloned the HDD to the SSD. Not sure exactly what I did but finally got it working. Will include some of the things I did incase it can help someone in the future.

    I realized the other night I only switched to HDD to AHCI from RAID. So I disabled the HDD in BIOS booted only the SSD and followed the steps to switch the drive to AHCI. I restarted the machine and enabled the HDD went into boot options and set the SSD to option #1 and HDD to option #2.
    It was still booting from the HDD drive. I was going to try running dban but the asus bios had secure boot locked and I didnt feel comfortable deleting the keys to make it boot not in secure mood as I never messed around in that area and didnt want to brick the computer.

    So I decided that if I only enabled the HDD and set it back to RAID mode the enable the SSD while leaving it in AHCI on startup if the BIOS was set to AHCI it would not boot from the HDD. When I tried this it booted from the HDD and gave the BSOD error. Then I went back into BIOS and saw that HDD was set to boot option #1 and SSD Boot option #2. I switched it so the SSD was boot option #1 and on boot it started from the SSD. I was able to wipe the HDD in disk management and I restarted the computer and it booted fine again.

    Not sure exactly how it finally worked as I know triple checked the boot options on the other startups.

    Again chillinmichael thanks for your replys.

  8. #8
    ROG Guru: Orange Belt Array chilinmichael's Avatar
    Join Date
    Dec 2012
    Reputation
    16
    Posts
    372

    Glad you got it figured out Scoobs! :-) Happy computing! Hopefully see you out there on Steam/Origin with some games!
    Asus G20CB - Core i7 6700, Nvidia GTX980, 16GB Ram, 256GB SK Hynix SSD, 1TB Samsung SSD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •