Page 3 of 3 FirstFirst 1 2 3
Results 21 to 23 of 23
  1. #21
    ROG Enthusiast Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    35

    I expirience same problem

    ASUS ROG G752VM with GTX1060
    i7 6700HK
    16GB RAM
    256 GB m.2 system disk
    1TB SATA SSD disk on which i store data

    XG Station 2 with ROG STRIX GTX1080TI GAMING

    Tested on GR Wildlands, Full HD, ultra settings, on GTX1060 and GTX1080TI I got around same results (about 40 FPS)

    Looking forward for new NVIDIA drivers, new Thunderbold drivers (if they can fix something) and new XGS2 firmware

    I spent a lot of money for all of this, about 3.300 USD all ASUS products (in Croatia hardware is more expensive).

    So, I hope this is no waste of money.

    If I can connect 4K monitor and got around 85% precent of GTX1080TI power, I'll buy it. But I don't need 4K monitor if GTX1080TI gives me power like integrated GTX1060

    Few tests with XGS2 AND GTX1080TI (full HD with ultra settings)
    GR: Wildlands: 40 fps
    WatchDogs 2: 40-50 fps
    Mafia 3: around 60 fps (ok, this one is better than my integrated gtx1060)
    Dishonored 2: 45 -50 fps
    Last edited by ISTIMAC; 04-19-2017 at 11:42 AM.

  2. #22
    Moderator Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    241

    Hi joey.ken,

    I have just sent you the XG STATION 2 Turbo firmware for you to evaluate.
    Please kindly give it a try and let us know the result at your end.

    regards,

    Quote Originally Posted by joey.ken View Post
    I go Kaer Morhen and take the photo at same place ,yes it can reach to 60FPS ,but when you go around Kaer Morhen the FPS is drop to about 45-

    50 most of time...in 1080p Ultra for everything, VSYNC OFF

    http://i.imgur.com/gGKqAuK.jpg

    http://i.imgur.com/kK7o3Sj.jpg

    This problem really drive me crazy Orz.......i have no idea which part of my hardware go wrong

    i got the TB3 laptop with external monitor and all driver setup.................crying.......

  3. #23
    Moderator Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    241

    Hi ISTIMAC,

    I have just sent you the Turbo Performance firmware with private message function.
    Please kindly give it a try and let us know how's the performance turn out after this update.

    Many thanks.

    regards,

    regards,

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •