Results 1 to 10 of 21

Threaded View

  1. #1
    ROG Member Array Dean72 PC Specs
    Dean72 PC Specs
    MotherboardSTRIX Z270G
    ProcessorIntel Core i 7700K
    Memory (part number)HYPERX PREDATOR DDR4 3333 MHz 2x 8GB
    Graphics Card #1NVIDIA 1080Ti
    MonitorAcer PREDATOR 27"
    Storage #1SAMSUNG 500GB EVO
    Storage #2WD Black Caviar 1TB
    CPU CoolerHYPER 212 EVO
    CaseZalman Z1
    Power SupplyFORTRON 700W
    Mouse RAZER DEATH ADDER 2013
    Headset ZALMAN
    Mouse Pad RAZER
    Headset/Speakers ZALMAN
    OS WINDOWS 10 x64

    Join Date
    Apr 2017
    Reputation
    10
    Posts
    7

    OS WONT BOOT with XMP active (HYPERX PREDATOR 2x 8GB 3333MHz)

    Hello guys,

    thank you all in advance.

    Recently I bought new PC, everything works correctly except my DDR4 memory module (HYPERX PREDATOR 2x 8GB 3333MHz).

    Problem is, when I swith to XMP profile in BIOS, system wont boot, or my CPU stays at its default 800Mhz speed and wont moove any higher even when it is under heavy load. I have mother board ROG STRIX Z270G, CPU: Core i7 7700k.

    I've already tried to switch jumpers on my MB to get extra voltage for my CPU but it didn't solved my problem. This memory is on the supported vendor list so I don't understand why it causing troubles to run it whit XMP.

    I would like to ask you kindly for you advice. Should I wait for new BIOS upgrade (mine is already upgraded to the newest) or switch to another memory module? Or perhaps some manual settings instead of XMP? Thank you for your time.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •