Results 1 to 7 of 7
  1. #1
    ROG Enthusiast Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    27

    Xonar U7 driver question

    I'm currently using driver version 4.16 from 20 Oct 2015 (Win 10 x64). I saw there is version 4.14 (?!) from 13 July 2016 available with beta support for Dolby digital live. My question is: is the (newer) driver worth installing? Is everything working?

  2. #2
    ROG Member Array
    Join Date
    Sep 2013
    Reputation
    10
    Posts
    10

    I have the Xonar U7 connected to a Logitech Z906 with those drivers and everything seems to be working fine, including the Dolby Home Theater v4 and the Dolby Digital Live included with it.
    As a heads up, i warn you NOT to update Windows 10 to the new "Creators Update", because it seems to have broken Dolby Digital Live & DTS Connect... AGAIN!!!

  3. #3
    ROG Enthusiast Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    27

    Quote Originally Posted by bct25 View Post
    I have the Xonar U7 connected to a Logitech Z906 with those drivers and everything seems to be working fine, including the Dolby Home Theater v4 and the Dolby Digital Live included with it.
    As a heads up, i warn you NOT to update Windows 10 to the new "Creators Update", because it seems to have broken Dolby Digital Live & DTS Connect... AGAIN!!!
    Thanks for the heads up

    Have you tried reinstalling the driver? Have you notified Asus about this? It's a shame that the driver is still in beta after 9 months...

  4. #4
    ROG Member Array
    Join Date
    Sep 2013
    Reputation
    10
    Posts
    10

    Quote Originally Posted by wh1sper View Post
    Thanks for the heads up

    Have you tried reinstalling the driver? Have you notified Asus about this? It's a shame that the driver is still in beta after 9 months...
    I did and to no avail. I haven't notified to ASUS, because it seems it's not a problem with their drivers, but from Microsoft. Other user's who own different equipment (Creative Sound Blaster and Realtek HD) are having the exact same problem, and the only way to fix it is to roll back to Windows 10 Anniversary Update (or buy a HDMI receiver witch, personally, is NOT a valid option for me) , so if i complain to ASUS they're just gonna tell me it's not their fault and to complain to Microsoft.

    Here's the link that kinda proves that's Microsoft mess at work:
    https://answers.microsoft.com/en-us/...9-0af6f0b284df
    Last edited by bct25; 04-12-2017 at 05:26 PM.

  5. #5
    ROG Enthusiast Array
    Join Date
    Jun 2016
    Reputation
    10
    Posts
    27

    Do tell when there is a fix available



    Quote Originally Posted by bct25 View Post
    I did and to no avail. I haven't notified to ASUS, because it seems it's not a problem with their drivers, but from Microsoft. Other user's who own different equipment (Creative Sound Blaster and Realtek HD) are having the exact same problem, and the only way to fix it is to roll back to Windows 10 Anniversary Update (or buy a HDMI receiver witch, personally, is NOT a valid option for me) , so if i complain to ASUS they're just gonna tell me it's not their fault and to complain to Microsoft.

    Here's the link that kinda proves that's Microsoft mess at work:
    https://answers.microsoft.com/en-us/...9-0af6f0b284df

  6. #6
    ROG Member Array
    Join Date
    Mar 2017
    Reputation
    10
    Posts
    6

    Quote Originally Posted by bct25 View Post
    I did and to no avail. I haven't notified to ASUS, because it seems it's not a problem with their drivers, but from Microsoft. Other user's who own different equipment (Creative Sound Blaster and Realtek HD) are having the exact same problem, and the only way to fix it is to roll back to Windows 10 Anniversary Update (or buy a HDMI receiver witch, personally, is NOT a valid option for me) , so if i complain to ASUS they're just gonna tell me it's not their fault and to complain to Microsoft.

    Here's the link that kinda proves that's Microsoft mess at work:
    https://answers.microsoft.com/en-us/...9-0af6f0b284df
    Uhh I don't know what alternate reality I live in but I've been on the fast ring of preview builds for windows 10 since the anniversary update and DDL works perfectly fine for me on every preview build. Creative sound blaster X-Fi With drivers from December 2015. I have a logitech z906 and I can see it being decoded. However my Asus Xonar does not. So I place blame on Asus.

    Click image for larger version. 

Name:	DDLworking.JPG 
Views:	1 
Size:	99.9 KB 
ID:	64141

  7. #7
    ROG Member Array
    Join Date
    Sep 2013
    Reputation
    10
    Posts
    10


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •