Page 2 of 2 FirstFirst 1 2
Results 11 to 11 of 11
  1. #11
    ROG Guru: Yellow Belt Array andyliu PC Specs
    andyliu PC Specs
    MotherboardCrosshair VII Hero
    ProcessorAMD Ryzen 7 3700X
    Memory (part number)(32GB) 2*F4-3200C14D-16GFX
    Graphics Card #1EVGA 980 FTW
    Storage #1Samsung Evo 850 500GB
    Storage #2Mushkin Enhanced ECO3 480GB
    CPU CoolerCorsair H105
    CaseCooler Master H500M
    Power SupplyThermaltake TOUGHPOWER 750W
    Keyboard Logitech G910
    Mouse Logitech G502
    OS Windows 10 Pro
    Network RouterASUS RT-AC3100 + PCE-AC88

    Join Date
    Apr 2017
    Reputation
    14
    Posts
    169

    Quote Originally Posted by DerpyBlake View Post
    Can't even flash BIOS, nothing happens when I press the bios button. Pretty sure it's just RMA time
    I made mistake before, this is my check list when USB flash back not working
    make sure the USB is formatted FAT32
    the file is renamed C6H.CAP and placed @ root
    plugged in @ right USB slot
    press and hold the BIOS flash back for 3-5 sec.

    oh and, if you didn't power off the system completely (kill the power to psu), you should also do it before attempting to do bios flash back.

    also, as other point out, could be issue with the ek waterblock
    here is quick google result.
    http://www.overclock.net/t/1624612/1...hero-issues/30

    Good luck
    Last edited by andyliu; 06-04-2017 at 11:54 PM.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •