Results 1 to 10 of 97

Threaded View

  1. #11
    New ROGer Array lazoli PC Specs
    lazoli PC Specs
    MotherboardAsus X299 E-Gaming
    ProcessorIntel Core i7 7820X
    Memory (part number)Corsair Vengeance RGB LED 32GB (CMR32GX4M4C3000C15)
    Graphics Card #1Nvidia GTX 1080 Founders Edition
    MonitorAsus ROG Swift PG287Q
    Storage #1Samsung 850 Evo
    Storage #2Samsung 960 Evo
    CPU CoolerNoctua NH-U12S
    CaseCorsair 570X RGB
    Power SupplySeaSonic Platinum PLATINUM-860 SS-860XP2
    Keyboard Asus Claymore Core
    Mouse Asus Gladius II
    Headset Sennheiser Game Zero
    Mouse Pad Asus Sheath
    OS Windows 10 Pro x64
    Accessory #1 Xbox One Controller
    Accessory #2 CableMod Addressable RGB Strip x2
    lazoli's Avatar
    Join Date
    Aug 2017
    Reputation
    10
    Posts
    10

    Quote Originally Posted by blueglue View Post
    I have exactly the same problem. (see pic)

    My Gladius II arrived on Sunday and i installed the latest Armoury which prompted the latest firmware 0180 . The mouse worked whilst the update occurred and when it finished all button cannot be changed. the middle mouse button works as a left click (sort of) and the right mouse button dims the display. Tried it on my gaming rig and laptop with the same results.
    If i unplug the mouse and hold down the three main mouse buttons when plugging in it goes through the firware update again and works normal until the update is done again.
    I only purchased this mouse to go with the ROG Posiedon 1080ti i purchasedas i nice colourful upgrade over my old RAT 5 mouse but is bugging the hell out of me. Especially when ive just spend £1000 on ROG products this week.

    Can you not just revert to the old firmware whilst you are fixing the current issue?

    Tom
    Same exact thing. Updated firmware through the new Armoury. Buttons behaved exactly like you described. Returned it and got a replacement unit thinking it was the mouse. Same issue. Called Asus support. After he made me install every single Armoury version, the very first one(1.01.08) brought back the mouse to life. Reinstalled windows and have not put back Armoury on my system again. Nothing but problems.*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •