Results 1 to 2 of 2
  1. #1
    ROG Guru: Yellow Belt Array Not_Enough_Rage PC Specs
    Not_Enough_Rage PC Specs
    Laptop (Model)Phhhtt!
    MotherboardMaximus VIII Extreme
    ProcessorIntel i7 6700K 4GHZ LGA1151
    Memory (part number)G.Skill RipJaws V 3200MB 16GB (8x2) CL14
    Graphics Card #1Zotac GeForce 1080ti Amp! Extreme
    Graphics Card #2Maybe next year.
    Graphics Card #3Not likely.
    Graphics Card #4You think I`m Mr. Moneybags!
    Sound CardROG Supreme FX
    MonitorAsus PG27AQ
    Storage #1Samsung 850EVO 500GB, Samsung 860EVO 1TB
    Storage #2Western Digital Black 1TB 7200RPM
    CPU CoolerCorsair H110i
    CaseCorsair Graphite 780T
    Power SupplyEVGA SuperNova 1000 P2 Platinum
    Keyboard G,Skill RipJaws KM780 RGB Cherry
    Mouse G.Skill RipJaws MX780
    Headset Just the holes in my head.
    Mouse Pad Corsair MM300 Extended
    Headset/Speakers Cambridge Soundworks 5.1
    OS Microsoft Windows 10 64Bit
    Network RouterComcast Cable Blast 300MB
    Accessory #1 LG Blu-Ray Optical Drive
    Accessory #2 Gonna put some LED bling in there.
    Accessory #3 No, this is a man`s PC!
    Not_Enough_Rage's Avatar
    Join Date
    Jun 2016
    Reputation
    35
    Posts
    167

    Why Does Tom Clany`s The Division Take So Long To Load

    Those that play TCTD will be more familiar with what I`m asking here. When I click play from the game start page, it takes longer than usual for the game to load. And then when I click continue to connect to the game server, it also takes too long. Even in the game when I start different missions, whenever the"game loading" circle is loading a game, it takes too long. Sometimes it stop loading.
    I don`t know if it has to do with anything, but during these long load times, i notice that the FPS rate go as low as 2 or 3 FPS. It used to be around 100 - 200 FPS.while loading the game. Is there an issue with the server, or with my GPU and game settings?

    I have deleted and re-installed the game 2 times already. It has made the tearing I had stop. I don`t have to use V-sync or Triple Buffering anymore, so the Global Settings for the GPU are set back to default. for the game settings I let it decide the settings. But the long loading times did start to happen after I re-installed the game both times.
    Last edited by Not_Enough_Rage; 06-08-2017 at 12:46 PM.

  2. #2
    AS185
    Guest
    I think it's an issue with the game. My colleague has The Division, running under maximum graphical setting's and no drops in frame rates. He doesn't have a top of the line system as I but does possess an Geforce 1070. However, I noticed that the game does take long to load while connecting to the server. Hopefully Ubisoft have resolved this problem by now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •